blob: d6b7130208b39d26249c116e537c44a389511cad [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Collection of simple PIN or passphrase entry dialogs"
2DESCRIPTION = "\
3 Pinentry is a collection of simple PIN or passphrase entry dialogs which \
4 utilize the Assuan protocol as described by the aegypten project; see \
5 http://www.gnupg.org/aegypten/ for details."
6
7HOMEPAGE = "http://www.gnupg.org/related_software/pinentry/index.en.html"
8LICENSE = "GPLv2"
9LIC_FILES_CHKSUM = "file://COPYING;md5=cbbd794e2a0a289b9dfcc9f513d1996e"
10
11inherit autotools
12
Patrick Williamsf1e5d692016-03-30 15:21:19 -050013DEPENDS = "gettext-native"
14
Patrick Williamsc124f4f2015-09-15 14:41:29 -050015SRC_URI = "ftp://ftp.gnupg.org/gcrypt/${BPN}/${BPN}-${PV}.tar.bz2"
16
17SRC_URI[md5sum] = "f51d454f921111b5156a2291cbf70278"
18SRC_URI[sha256sum] = "fd8bc1592ceb22bb492b07cb29b1b140bb882c859e6503b974254c0a4b4134d1"
19
20EXTRA_OECONF = "--disable-rpath \
21 --disable-dependency-tracking \
22 "
23
24PACKAGECONFIG ??= "ncurses libcap"
25
26PACKAGECONFIG[ncurses] = "--enable-ncurses --with-ncurses-include-dir=${STAGING_INCDIR}, --disable-ncurses, ncurses"
27PACKAGECONFIG[libcap] = "--with-libcap, --without-libcap, libcap"
28PACKAGECONFIG[qt4] = "--enable-pinentry-qt4, --disable-pinentry-qt4, qt4-x11"
29PACKAGECONFIG[qt4_clipboard] = "--enable-pinentry-qt4-clipboard --enable-pinentry-qt4, --disable-pinentry-qt4-clipboard, qt4-x11"
30PACKAGECONFIG[gtk2] = "--enable-pinentry-gtk2, --disable-pinentry-gtk2, gtk+ glib-2.0"
31
32#To use libsecret, add meta-gnome
33PACKAGECONFIG[secret] = "--enable-libsecret, --disable-libsecret, libsecret"