blob: 7081afbeb1d9d4dc7632c6f940310893a923f198 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "A C program to run all installed ptests"
2DESCRIPTION = "The ptest-runner2 package installs a ptest-runner \
3program which loops through all installed ptest test suites and \
4runs them in sequence."
5HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/ptest-runner2/about/"
6
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
9
10SRCREV = "8bfdf946e784f4d5757bebee1fbc4b4a3d7a95c4"
11PV = "2.0+git${SRCPV}"
12
13SRC_URI = "git://git.yoctoproject.org/ptest-runner2"
14S = "${WORKDIR}/git"
15
16FILES_${PN} = "${bindir}/ptest-runner"
17
18EXTRA_OEMAKE = "-e MAKEFLAGS="
19
20do_compile () {
21 oe_runmake
22}
23
24do_install () {
25 install -D -m 0755 ${WORKDIR}/git/ptest-runner ${D}${bindir}/ptest-runner
26}