blob: 82e5c3bc5e5a2bc731f427b068f57ddc86198371 [file] [log] [blame]
Andrew Geisslera2681d92020-10-16 10:17:07 -05001# Copyright (C) 2020 Armin Kuster <akuster808@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "Musl-nscd is an implementation of the NSCD protocol, suitable for use with musl and with standard NSS modules"
5HOMEPAGE = "https://github.com/pikhq/musl-nscd"
6LICENSE = "MIT"
Andrew Geissler615f2f12022-07-15 14:00:58 -05007LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=fff9baeb9a392879d7fb25ba3a2696e4"
Andrew Geisslera2681d92020-10-16 10:17:07 -05008SECTION = "utils"
9
Andrew Geissler4b7c1152020-11-30 19:55:29 -060010DEPENDS += "flex-native bison-native flex bison"
11
Andrew Geissler615f2f12022-07-15 14:00:58 -050012PV = "1.1.0"
Andrew Geisslera2681d92020-10-16 10:17:07 -050013
Andrew Geissler615f2f12022-07-15 14:00:58 -050014SRCREV = "cddd6be6c629ca96f2d2e74ee52daf12bbef1f83"
Andrew Geissler595f6302022-01-24 19:11:47 +000015SRC_URI = "git://github.com/pikhq/musl-nscd;branch=master;protocol=https \
Andrew Geissler32b11992021-03-31 13:37:05 -050016 file://0001-nsswitch.y-Replace-empty-bison-extension.patch \
Andrew Geissler4b7c1152020-11-30 19:55:29 -060017 "
Andrew Geisslera2681d92020-10-16 10:17:07 -050018
19UPSTREAM_CHECK_COMMITS = "1"
20
21inherit autotools-brokensep
22
23S = "${WORKDIR}/git"
24
25do_configure () {
26 # no debug set -s flag
27 sed -i -e 's/LDFLAGS_AUTO=-s/LDFLAGS_AUTO=/' ${S}/configure
28 ${S}/configure ${CONFIGUREOPTS} ${EXTRA_OECONF}
29}
30
31do_compile () {
32 oe_runmake
33}
34
35do_install () {
36 make DESTDIR=${D} install
37}
38
39COMPATIBLE_HOST = ".*-musl.*"