blob: d724287d668f7c7c129c2b9172d8c5cefd350d46 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "Protocol Buffers - structured data serialisation mechanism"
2DESCRIPTION = "This is protobuf-c, a C implementation of the Google Protocol Buffers data \
3serialization format. It includes libprotobuf-c, a pure C library that \
4implements protobuf encoding and decoding, and protoc-c, a code generator that \
5converts Protocol Buffer .proto files to C descriptor code, based on the \
6original protoc. protobuf-c formerly included an RPC implementation; that code \
7has been split out into the protobuf-c-rpc project."
8HOMEPAGE = "https://github.com/protobuf-c/protobuf-c"
9SECTION = "console/tools"
10LICENSE = "BSD-2-Clause"
Andrew Geissler615f2f12022-07-15 14:00:58 -050011LIC_FILES_CHKSUM = "file://LICENSE;md5=9f725889e0d77383e26cb42b0b62cea2"
Andrew Geisslereff27472021-10-29 15:35:00 -050012
13DEPENDS = "protobuf-native protobuf"
14
Andrew Geissler595f6302022-01-24 19:11:47 +000015SRC_URI = "git://github.com/protobuf-c/protobuf-c.git;branch=master;protocol=https"
Andrew Geissler615f2f12022-07-15 14:00:58 -050016SRCREV = "abc67a11c6db271bedbb9f58be85d6f4e2ea8389"
Andrew Geisslereff27472021-10-29 15:35:00 -050017
18S = "${WORKDIR}/git"
19
20inherit autotools pkgconfig
21
Andrew Geissler595f6302022-01-24 19:11:47 +000022export PROTOC = "${STAGING_BINDIR_NATIVE}/protoc"
23
Andrew Geisslereff27472021-10-29 15:35:00 -050024# After several fix attempts there is still a race between generating
25# t.test-full.pb.h and compiling cxx_generate_packed_data.c despite
26# BUILT_SOURCES and explicit dependencies.
27PARALLEL_MAKE = ""
28
29PACKAGE_BEFORE_PN = "${PN}-compiler"
30
31FILES:${PN}-compiler = "${bindir}"
32
33RDEPENDS:${PN}-compiler = "protobuf-compiler"
34RDEPENDS:${PN}-dev += "${PN}-compiler"
35
36BBCLASSEXTEND = "native nativesdk"