blob: be58cdb71a42eb8dc69b76d7daeb73019cba605f [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "File type identification using libmagic"
2DESCRIPTION = "This module uses ctypes to access the libmagic file type \
3 identification library. It makes use of the local magic database and supports \
4 both textual and MIME-type output."
5HOMEPAGE = "http://github.com/ahupp/python-magic"
6
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=61495c152d794e6be5799a9edca149e3"
9
10PYPI_PACKAGE = "python-magic"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000011
12inherit pypi setuptools3
13
Andrew Geissler615f2f12022-07-15 14:00:58 -050014SRC_URI[sha256sum] = "c1ba14b08e4a5f5c31a302b7721239695b2f0f058d125bd5ce1ee36b9d9d3c3b"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000015
16RDEPENDS:${PN} += "file \
17 ${PYTHON_PN}-ctypes \
18 ${PYTHON_PN}-io \
19 ${PYTHON_PN}-logging \
20 ${PYTHON_PN}-shell"
21
22BBCLASSEXTEND = "native"