blob: b237c4873589a5295293ec86ffd9128c2a836f9b [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "The Python Programming Language"
2HOMEPAGE = "http://www.python.org"
3DESCRIPTION = "Python is a programming language that lets you work more quickly and integrate your systems more effectively."
4LICENSE = "PSF-2.0"
5SECTION = "devel/python"
6
7LIC_FILES_CHKSUM = "file://LICENSE;md5=4b8801e752a2c70ac41a5f9aa243f766"
8
9SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.xz \
10 file://run-ptest \
11 file://create_manifest3.py \
12 file://get_module_deps3.py \
13 file://python3-manifest.json \
14 file://check_build_completeness.py \
15 file://reformat_sysconfig.py \
16 file://cgi_py.patch \
17 file://0001-Do-not-add-usr-lib-termcap-to-linker-flags-to-avoid-.patch \
18 ${@bb.utils.contains('PACKAGECONFIG', 'tk', '', 'file://avoid_warning_about_tkinter.patch', d)} \
19 file://0001-Do-not-use-the-shell-version-of-python-config-that-w.patch \
20 file://python-config.patch \
21 file://0001-Makefile.pre-use-qemu-wrapper-when-gathering-profile.patch \
22 file://0001-python3-use-cc_basename-to-replace-CC-for-checking-c.patch \
23 file://0001-bpo-36852-proper-detection-of-mips-architecture-for-.patch \
24 file://crosspythonpath.patch \
25 file://0001-Use-FLAG_REF-always-for-interned-strings.patch \
26 file://0001-test_locale.py-correct-the-test-output-format.patch \
27 file://0017-setup.py-do-not-report-missing-dependencies-for-disa.patch \
28 file://0001-Makefile-do-not-compile-.pyc-in-parallel.patch \
29 file://0020-configure.ac-setup.py-do-not-add-a-curses-include-pa.patch \
30 file://0001-Skip-failing-tests-due-to-load-variability-on-YP-AB.patch \
31 file://0001-test_ctypes.test_find-skip-without-tools-sdk.patch \
32 file://makerace.patch \
33 file://0001-sysconfig.py-use-platlibdir-also-for-purelib.patch \
34 file://0001-Lib-pty.py-handle-stdin-I-O-errors-same-way-as-maste.patch \
Patrick Williams03907ee2022-05-01 06:28:52 -050035 file://0001-setup.py-Do-not-detect-multiarch-paths-when-cross-co.patch \
Andrew Geissler78b72792022-06-14 06:47:25 -050036 file://deterministic_imports.patch \
Andrew Geissler615f2f12022-07-15 14:00:58 -050037 file://0001-Avoid-shebang-overflow-on-python-config.py.patch \
38 file://0001-Mitigate-the-race-condition-in-testSockName.patch \
Andrew Geissler9aee5002022-03-30 16:27:02 +000039 "
40
41SRC_URI:append:class-native = " \
42 file://0001-Lib-sysconfig.py-use-prefix-value-from-build-configu.patch \
43 file://0001-distutils-sysconfig-append-STAGING_LIBDIR-python-sys.patch \
44 file://12-distutils-prefix-is-inside-staging-area.patch \
45 file://0001-Don-t-search-system-for-headers-libraries.patch \
46 "
Andrew Geissler615f2f12022-07-15 14:00:58 -050047SRC_URI[sha256sum] = "8437efd5b106ef0a75aabfbf23d880625120a73a86a22ade4d2e2e68d7b74486"
Andrew Geissler9aee5002022-03-30 16:27:02 +000048
49# exclude pre-releases for both python 2.x and 3.x
50UPSTREAM_CHECK_REGEX = "[Pp]ython-(?P<pver>\d+(\.\d+)+).tar"
51UPSTREAM_CHECK_URI = "https://www.python.org/downloads/source/"
52
53CVE_PRODUCT = "python"
54
55# Upstream consider this expected behaviour
56CVE_CHECK_IGNORE += "CVE-2007-4559"
57# This is not exploitable when glibc has CVE-2016-10739 fixed.
58CVE_CHECK_IGNORE += "CVE-2019-18348"
59# These are specific to Microsoft Windows
60CVE_CHECK_IGNORE += "CVE-2020-15523 CVE-2022-26488"
Patrick Williams03907ee2022-05-01 06:28:52 -050061# The mailcap module is insecure by design, so this can't be fixed in a meaningful way.
62# The module will be removed in the future and flaws documented.
63CVE_CHECK_IGNORE += "CVE-2015-20107"
Andrew Geissler9aee5002022-03-30 16:27:02 +000064
65PYTHON_MAJMIN = "3.10"
66
67S = "${WORKDIR}/Python-${PV}"
68
69BBCLASSEXTEND = "native nativesdk"
70
71inherit autotools pkgconfig qemu ptest multilib_header update-alternatives
72
73MULTILIB_SUFFIX = "${@d.getVar('base_libdir',1).split('/')[-1]}"
74
75ALTERNATIVE:${PN}-dev = "python3-config"
76ALTERNATIVE_LINK_NAME[python3-config] = "${bindir}/python${PYTHON_MAJMIN}-config"
77ALTERNATIVE_TARGET[python3-config] = "${bindir}/python${PYTHON_MAJMIN}-config-${MULTILIB_SUFFIX}"
78
79
80DEPENDS = "bzip2-replacement-native libffi bzip2 openssl sqlite3 zlib virtual/libintl xz virtual/crypt util-linux-libuuid libtirpc libnsl2 autoconf-archive-native ncurses"
81DEPENDS:append:class-target = " python3-native"
82DEPENDS:append:class-nativesdk = " python3-native"
83
84# force to use the mutex+cond implementation (https://bugs.python.org/issue41710)
85CFLAGS += "-DHAVE_BROKEN_POSIX_SEMAPHORES"
86
87EXTRA_OECONF = " --without-ensurepip --enable-shared --with-platlibdir=${baselib}"
88EXTRA_OECONF:append:class-native = " --bindir=${bindir}/${PN}"
89
90export CROSSPYTHONPATH="${STAGING_LIBDIR_NATIVE}/python${PYTHON_MAJMIN}/lib-dynload/"
91
92EXTRANATIVEPATH += "python3-native"
93
94# LTO will be enabled via packageconfig depending upong distro features
95LTO:class-target = ""
96
97CACHED_CONFIGUREVARS = " \
98 ac_cv_file__dev_ptmx=yes \
99 ac_cv_file__dev_ptc=no \
100 ac_cv_working_tzset=yes \
101"
102
103# PGO currently causes builds to not be reproducible so disable by default, see YOCTO #13407
104PACKAGECONFIG:class-target ??= "readline gdbm ${@bb.utils.filter('DISTRO_FEATURES', 'lto', d)}"
105PACKAGECONFIG:class-native ??= "readline gdbm"
106PACKAGECONFIG:class-nativesdk ??= "readline gdbm"
107PACKAGECONFIG[readline] = ",,readline"
108# Use profile guided optimisation by running PyBench inside qemu-user
109PACKAGECONFIG[pgo] = "--enable-optimizations,,qemu-native"
110PACKAGECONFIG[tk] = ",,tk"
111PACKAGECONFIG[gdbm] = ",,gdbm"
112PACKAGECONFIG[lto] = "--with-lto,,"
113
114do_configure:prepend () {
115 mkdir -p ${B}/Modules
116 cat > ${B}/Modules/Setup.local << EOF
117*disabled*
118${@bb.utils.contains('PACKAGECONFIG', 'gdbm', '', '_gdbm _dbm', d)}
119${@bb.utils.contains('PACKAGECONFIG', 'readline', '', 'readline', d)}
120EOF
121}
122
123CPPFLAGS:append = " -I${STAGING_INCDIR}/ncursesw -I${STAGING_INCDIR}/uuid"
124
125EXTRA_OEMAKE = '\
126 STAGING_LIBDIR=${STAGING_LIBDIR} \
127 STAGING_INCDIR=${STAGING_INCDIR} \
128 LIB=${baselib} \
129'
130
131do_compile:prepend:class-target() {
132 if ${@bb.utils.contains('PACKAGECONFIG', 'pgo', 'true', 'false', d)}; then
133 qemu_binary="${@qemu_wrapper_cmdline(d, '${STAGING_DIR_TARGET}', ['${B}', '${STAGING_DIR_TARGET}/${base_libdir}'])}"
134 cat >pgo-wrapper <<EOF
135#!/bin/sh
136cd ${B}
137$qemu_binary "\$@"
138EOF
139 chmod +x pgo-wrapper
140 fi
141}
142
143do_install:prepend() {
144 ${WORKDIR}/check_build_completeness.py ${T}/log.do_compile
145}
146
147do_install:append:class-target() {
148 oe_multilib_header python${PYTHON_MAJMIN}/pyconfig.h
149}
150
151do_install:append:class-native() {
152 # Make sure we use /usr/bin/env python
153 for PYTHSCRIPT in `grep -rIl ${bindir}/${PN}/python ${D}${bindir}/${PN}`; do
154 sed -i -e '1s|^#!.*|#!/usr/bin/env python3|' $PYTHSCRIPT
155 done
156 # Add a symlink to the native Python so that scripts can just invoke
157 # "nativepython" and get the right one without needing absolute paths
158 # (these often end up too long for the #! parser in the kernel as the
159 # buffer is 128 bytes long).
160 ln -s python3-native/python3 ${D}${bindir}/nativepython3
161
162 # Remove the opt-1.pyc and opt-2.pyc files. There are over 3,000 of them
163 # and the overhead in each recipe-sysroot-native isn't worth it, particularly
164 # when they're only used for python called with -O or -OO.
165 #find ${D} -name *opt-*.pyc -delete
166 # Remove all pyc files. There are a ton of them and it is probably faster to let
167 # python create the ones it wants at runtime rather than manage in the sstate
168 # tarballs and sysroot creation.
169 find ${D} -name *.pyc -delete
170
Andrew Geissler78b72792022-06-14 06:47:25 -0500171 # Nothing should be looking into ${B} for python3-native
172 sed -i -e 's:${B}:/build/path/unavailable/:g' \
173 ${D}/${libdir}/python${PYTHON_MAJMIN}/config-${PYTHON_MAJMIN}${PYTHON_ABI}*/Makefile
Andrew Geissler9aee5002022-03-30 16:27:02 +0000174}
175
176do_install:append() {
177 for c in ${D}/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata*.py; do
178 python3 ${WORKDIR}/reformat_sysconfig.py $c
179 done
180 rm -f ${D}${libdir}/python${PYTHON_MAJMIN}/__pycache__/_sysconfigdata*.cpython*
181
182 mkdir -p ${D}${libdir}/python-sysconfigdata
183 sysconfigfile=`find ${D} -name _sysconfig*.py`
Andrew Geissler9aee5002022-03-30 16:27:02 +0000184 sed -i \
185 -e "s,^ 'LIBDIR'.*, 'LIBDIR': '${STAGING_LIBDIR}'\,,g" \
186 -e "s,^ 'INCLUDEDIR'.*, 'INCLUDEDIR': '${STAGING_INCDIR}'\,,g" \
187 -e "s,^ 'CONFINCLUDEDIR'.*, 'CONFINCLUDEDIR': '${STAGING_INCDIR}'\,,g" \
188 -e "/^ 'INCLDIRSTOMAKE'/{N; s,/usr/include,${STAGING_INCDIR},g}" \
189 -e "/^ 'INCLUDEPY'/s,/usr/include,${STAGING_INCDIR},g" \
Andrew Geissler78b72792022-06-14 06:47:25 -0500190 -e "s,${B},/build/path/unavailable/,g" \
191 $sysconfigfile
192 cp $sysconfigfile ${D}${libdir}/python-sysconfigdata/_sysconfigdata.py
193
Andrew Geissler9aee5002022-03-30 16:27:02 +0000194
195 # Unfortunately the following pyc files are non-deterministc due to 'frozenset'
196 # being written without strict ordering, even with PYTHONHASHSEED = 0
197 # Upstream is discussing ways to solve the issue properly, until then let's
198 # just not install the problematic files.
199 # More info: http://benno.id.au/blog/2013/01/15/python-determinism
200 rm -f ${D}${libdir}/python${PYTHON_MAJMIN}/test/__pycache__/test_range.cpython*
201 rm -f ${D}${libdir}/python${PYTHON_MAJMIN}/test/__pycache__/test_xml_etree.cpython*
202
Andrew Geisslerd5838332022-05-27 11:33:10 -0500203 # Similar to the above, we're getting reproducibility issues with
204 # /usr/lib/python3.10/__pycache__/traceback.cpython-310.pyc
205 # so remove it too
206 rm -f ${D}${libdir}/python${PYTHON_MAJMIN}/__pycache__/traceback.cpython*
207
Andrew Geissler9aee5002022-03-30 16:27:02 +0000208 # Remove the opt-1.pyc and opt-2.pyc files. They effectively waste space on embedded
209 # style targets as they're only used when python is called with the -O or -OO options
210 # which is rare.
211 find ${D} -name *opt-*.pyc -delete
212}
213
214do_install:append:class-nativesdk () {
215 # Make sure we use /usr/bin/env python
216 for PYTHSCRIPT in `grep -rIl ${bindir}/python ${D}${bindir}`; do
217 sed -i -e '1s|^#!.*|#!/usr/bin/env python3|' $PYTHSCRIPT
218 done
219 create_wrapper ${D}${bindir}/python${PYTHON_MAJMIN} TERMINFO_DIRS='${sysconfdir}/terminfo:/etc/terminfo:/usr/share/terminfo:/usr/share/misc/terminfo:/lib/terminfo' PYTHONNOUSERSITE='1'
220}
221
222SSTATE_SCAN_FILES += "Makefile _sysconfigdata.py"
223SSTATE_HASHEQUIV_FILEMAP = " \
224 populate_sysroot:*/lib*/python3*/_sysconfigdata*.py:${TMPDIR} \
225 populate_sysroot:*/lib*/python3*/_sysconfigdata*.py:${COREBASE} \
226 populate_sysroot:*/lib*/python3*/config-*/Makefile:${TMPDIR} \
227 populate_sysroot:*/lib*/python3*/config-*/Makefile:${COREBASE} \
228 populate_sysroot:*/lib*/python-sysconfigdata/_sysconfigdata.py:${TMPDIR} \
229 populate_sysroot:*/lib*/python-sysconfigdata/_sysconfigdata.py:${COREBASE} \
230 "
231PACKAGE_PREPROCESS_FUNCS += "py_package_preprocess"
232
233py_package_preprocess () {
234 # Remove references to buildmachine paths in target Makefile and _sysconfigdata
235 sed -i -e 's:--sysroot=${STAGING_DIR_TARGET}::g' -e s:'--with-libtool-sysroot=${STAGING_DIR_TARGET}'::g \
236 -e 's|${DEBUG_PREFIX_MAP}||g' \
237 -e 's:${HOSTTOOLS_DIR}/::g' \
238 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
239 -e 's:${RECIPE_SYSROOT}::g' \
240 -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \
241 ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/config-${PYTHON_MAJMIN}${PYTHON_ABI}*/Makefile \
242 ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata*.py \
243 ${PKGD}/${bindir}/python${PYTHON_MAJMIN}-config
244
245 # Reformat _sysconfigdata after modifying it so that it remains
246 # reproducible
247 for c in ${PKGD}/${libdir}/python${PYTHON_MAJMIN}/_sysconfigdata*.py; do
248 python3 ${WORKDIR}/reformat_sysconfig.py $c
249 done
250
251 # Recompile _sysconfigdata after modifying it
252 cd ${PKGD}
253 sysconfigfile=`find . -name _sysconfigdata_*.py`
254 ${STAGING_BINDIR_NATIVE}/python3-native/python3 \
255 -c "from py_compile import compile; compile('$sysconfigfile')"
256 ${STAGING_BINDIR_NATIVE}/python3-native/python3 \
257 -c "from py_compile import compile; compile('$sysconfigfile', optimize=1)"
258 ${STAGING_BINDIR_NATIVE}/python3-native/python3 \
259 -c "from py_compile import compile; compile('$sysconfigfile', optimize=2)"
260 cd -
261
262 mv ${PKGD}/${bindir}/python${PYTHON_MAJMIN}-config ${PKGD}/${bindir}/python${PYTHON_MAJMIN}-config-${MULTILIB_SUFFIX}
263
264 #Remove the unneeded copy of target sysconfig data
265 rm -rf ${PKGD}/${libdir}/python-sysconfigdata
266}
267
268# We want bytecode precompiled .py files (.pyc's) by default
269# but the user may set it on their own conf
270INCLUDE_PYCS ?= "1"
271
272python(){
273 import collections, json
274
275 filename = os.path.join(d.getVar('THISDIR'), 'python3', 'python3-manifest.json')
276 # This python changes the datastore based on the contents of a file, so mark
277 # that dependency.
278 bb.parse.mark_dependency(d, filename)
279
280 with open(filename) as manifest_file:
281 manifest_str = manifest_file.read()
282 json_start = manifest_str.find('# EOC') + 6
283 manifest_file.seek(json_start)
284 manifest_str = manifest_file.read()
285 python_manifest = json.loads(manifest_str, object_pairs_hook=collections.OrderedDict)
286
287 # First set RPROVIDES for -native case
288 # Hardcoded since it cant be python3-native-foo, should be python3-foo-native
289 pn = 'python3'
290 rprovides = (d.getVar('RPROVIDES') or "").split()
291
292 # ${PN}-misc-native is not in the manifest
293 rprovides.append(pn + '-misc-native')
294
295 for key in python_manifest:
296 pypackage = pn + '-' + key + '-native'
297 if pypackage not in rprovides:
298 rprovides.append(pypackage)
299
300 d.setVar('RPROVIDES:class-native', ' '.join(rprovides))
301
302 # Then work on the target
303 include_pycs = d.getVar('INCLUDE_PYCS')
304
305 packages = d.getVar('PACKAGES').split()
306 pn = d.getVar('PN')
307
308 newpackages=[]
309 for key in python_manifest:
310 pypackage = pn + '-' + key
311
312 if pypackage not in packages:
313 # We need to prepend, otherwise python-misc gets everything
314 # so we use a new variable
315 newpackages.append(pypackage)
316
317 # "Build" python's manifest FILES, RDEPENDS and SUMMARY
318 d.setVar('FILES:' + pypackage, '')
319 for value in python_manifest[key]['files']:
320 d.appendVar('FILES:' + pypackage, ' ' + value)
321
322 # Add cached files
323 if include_pycs == '1':
324 for value in python_manifest[key]['cached']:
325 d.appendVar('FILES:' + pypackage, ' ' + value)
326
327 for value in python_manifest[key]['rdepends']:
328 # Make it work with or without $PN
329 if '${PN}' in value:
330 value=value.split('-', 1)[1]
331 d.appendVar('RDEPENDS:' + pypackage, ' ' + pn + '-' + value)
332
333 for value in python_manifest[key].get('rrecommends', ()):
334 if '${PN}' in value:
335 value=value.split('-', 1)[1]
336 d.appendVar('RRECOMMENDS:' + pypackage, ' ' + pn + '-' + value)
337
338 d.setVar('SUMMARY:' + pypackage, python_manifest[key]['summary'])
339
340 # Prepending so to avoid python-misc getting everything
341 packages = newpackages + packages
342 d.setVar('PACKAGES', ' '.join(packages))
343 d.setVar('ALLOW_EMPTY:${PN}-modules', '1')
344 d.setVar('ALLOW_EMPTY:${PN}-pkgutil', '1')
345
346 if "pgo" in d.getVar("PACKAGECONFIG").split() and not bb.utils.contains('MACHINE_FEATURES', 'qemu-usermode', True, False, d):
347 bb.fatal("pgo cannot be enabled as there is no qemu-usermode support for this architecture/machine")
348}
349
350# Files needed to create a new manifest
351
352do_create_manifest() {
353 # This task should be run with every new release of Python.
354 # We must ensure that PACKAGECONFIG enables everything when creating
355 # a new manifest, this is to base our new manifest on a complete
356 # native python build, containing all dependencies, otherwise the task
357 # wont be able to find the required files.
358 # e.g. BerkeleyDB is an optional build dependency so it may or may not
359 # be present, we must ensure it is.
360
361 cd ${WORKDIR}
362 # This needs to be executed by python-native and NOT by HOST's python
363 nativepython3 create_manifest3.py ${PYTHON_MAJMIN}
364 cp python3-manifest.json.new ${THISDIR}/python3/python3-manifest.json
365}
366
367# bitbake python -c create_manifest
368# Make sure we have native python ready when we create a new manifest
369addtask do_create_manifest after do_patch do_prepare_recipe_sysroot
370
371# manual dependency additions
372RRECOMMENDS:${PN}-core:append:class-nativesdk = " nativesdk-python3-modules"
373RRECOMMENDS:${PN}-crypt:append:class-target = " ${MLPREFIX}openssl ${MLPREFIX}ca-certificates"
374RRECOMMENDS:${PN}-crypt:append:class-nativesdk = " ${MLPREFIX}openssl ${MLPREFIX}ca-certificates"
375
376# For historical reasons PN is empty and provided by python3-modules
377FILES:${PN} = ""
378RPROVIDES:${PN}-modules = "${PN}"
379
380FILES:${PN}-pydoc += "${bindir}/pydoc${PYTHON_MAJMIN} ${bindir}/pydoc3"
381FILES:${PN}-idle += "${bindir}/idle3 ${bindir}/idle${PYTHON_MAJMIN}"
382
383# provide python-pyvenv from python3-venv
384RPROVIDES:${PN}-venv += "${MLPREFIX}python3-pyvenv"
385
386# package libpython3
387PACKAGES =+ "libpython3 libpython3-staticdev"
388FILES:libpython3 = "${libdir}/libpython*.so.*"
389FILES:libpython3-staticdev += "${libdir}/python${PYTHON_MAJMIN}/config-${PYTHON_MAJMIN}-*/libpython${PYTHON_MAJMIN}.a"
390INSANE_SKIP:${PN}-dev += "dev-elf"
391INSANE_SKIP:${PN}-ptest = "dev-deps"
392
393# catch all the rest (unsorted)
394PACKAGES += "${PN}-misc"
395RDEPENDS:${PN}-misc += "\
396 ${PN}-core \
397 ${PN}-email \
398 ${PN}-codecs \
399 ${PN}-pydoc \
400 ${PN}-pickle \
401 ${PN}-audio \
402 ${PN}-numbers \
403"
404RDEPENDS:${PN}-modules:append:class-target = " ${MLPREFIX}python3-misc"
405RDEPENDS:${PN}-modules:append:class-nativesdk = " ${MLPREFIX}python3-misc"
406FILES:${PN}-misc = "${libdir}/python${PYTHON_MAJMIN} ${libdir}/python${PYTHON_MAJMIN}/lib-dynload"
407
408# catch manpage
409PACKAGES += "${PN}-man"
410FILES:${PN}-man = "${datadir}/man"
411
412# See https://bugs.python.org/issue18748 and https://bugs.python.org/issue37395
413RDEPENDS:libpython3:append:libc-glibc = " libgcc"
414RDEPENDS:${PN}-ctypes:append:libc-glibc = " ${MLPREFIX}ldconfig"
415RDEPENDS:${PN}-ptest = "${PN}-modules ${PN}-tests ${PN}-dev unzip bzip2 libgcc tzdata-europe coreutils sed"
416RDEPENDS:${PN}-ptest:append:libc-glibc = " locale-base-tr-tr.iso-8859-9"
417RDEPENDS:${PN}-tkinter += "${@bb.utils.contains('PACKAGECONFIG', 'tk', '${MLPREFIX}tk ${MLPREFIX}tk-lib', '', d)}"
418RDEPENDS:${PN}-idle += "${@bb.utils.contains('PACKAGECONFIG', 'tk', '${PN}-tkinter ${MLPREFIX}tcl', '', d)}"
Andrew Geissler615f2f12022-07-15 14:00:58 -0500419DEV_PKG_DEPENDENCY = ""
Andrew Geissler9aee5002022-03-30 16:27:02 +0000420RDEPENDS:${PN}-pydoc += "${PN}-io"
421
422RDEPENDS:${PN}-tests:append:class-target = " ${MLPREFIX}bash"
423RDEPENDS:${PN}-tests:append:class-nativesdk = " ${MLPREFIX}bash"
424
425# Python's tests contain large numbers of files we don't need in the recipe sysroots
426SYSROOT_PREPROCESS_FUNCS += " py3_sysroot_cleanup"
427py3_sysroot_cleanup () {
428 rm -rf ${SYSROOT_DESTDIR}${libdir}/python${PYTHON_MAJMIN}/test
429}