blob: 094251ec811f7f6e29df356f7f93e9adca40d96a [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Linux Test Project"
2DESCRIPTION = "The Linux Test Project is a joint project with SGI, IBM, OSDL, and Bull with a goal to deliver test suites to the open source community that validate the reliability, robustness, and stability of Linux. The Linux Test Project is a collection of tools for testing the Linux kernel and related features."
3HOMEPAGE = "https://linux-test-project.github.io/"
4SECTION = "console/utils"
5LICENSE = "GPL-2.0-only & GPL-2.0-or-later & LGPL-2.0-or-later & LGPL-2.1-or-later & BSD-2-Clause"
6LIC_FILES_CHKSUM = "\
7 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://testcases/open_posix_testsuite/COPYING;md5=48b1c5ec633e3e30ec2cf884ae699947 \
9 file://testcases/network/can/filter-tests/COPYING;md5=5b155ea7d7f86eae8e8832955d8b70bc \
10"
11
12DEPENDS = "attr libaio libcap acl openssl zip-native"
13DEPENDS:append:libc-musl = " fts "
14EXTRA_OEMAKE:append:libc-musl = " LIBC=musl "
15EXTRA_OECONF:append:libc-musl = " LIBS=-lfts "
16
17# since ltp contains x86-64 assembler which uses the frame-pointer register,
18# set -fomit-frame-pointer x86-64 to handle cases where optimisation
19# is set to -O0 or frame pointers have been enabled by -fno-omit-frame-pointer
20# earlier in CFLAGS, etc.
21CFLAGS:append:x86-64 = " -fomit-frame-pointer"
Andrew Geissler615f2f12022-07-15 14:00:58 -050022TUNE_CCARGS:remove:x86 = "-mfpmath=sse"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000023
24CFLAGS:append:powerpc64 = " -D__SANE_USERSPACE_TYPES__"
25CFLAGS:append:mipsarchn64 = " -D__SANE_USERSPACE_TYPES__"
Andrew Geissler78b72792022-06-14 06:47:25 -050026SRCREV = "6f88e0f6f1d6eb12c48c902f50f47ecbd3b0f18a"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000027
28SRC_URI = "git://github.com/linux-test-project/ltp.git;branch=master;protocol=https \
29 file://0001-Remove-OOM-tests-from-runtest-mm.patch \
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000030 file://disable_hanging_tests.patch \
Andrew Geissler615f2f12022-07-15 14:00:58 -050031 file://0001-kvm-use-LD-instead-of-hardcoding-ld.patch \
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000032 "
33
34S = "${WORKDIR}/git"
35
36inherit autotools-brokensep pkgconfig
37
Andrew Geissler78b72792022-06-14 06:47:25 -050038# Version 20220527 added KVM test infrastructure which currently fails to build with gold due to
39# SORT_NONE in linker script which isn't supported by gold:
40# https://sourceware.org/bugzilla/show_bug.cgi?id=18097
41# https://github.com/linux-test-project/ltp/commit/3fce2064b54843218d085aae326c8f7ecf3a8c41#diff-39268f0855c634ca48c8993fcd2c95b12a65b79e8d9fa5ccd6b0f5a8785c0dd6R36
42LDFLAGS:append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd', '', d)}"
43
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000044TARGET_CC_ARCH += "${LDFLAGS}"
45
46export prefix = "/opt/${PN}"
47export exec_prefix = "/opt/${PN}"
48
49PACKAGECONFIG[numa] = "--with-numa, --without-numa, numactl,"
50EXTRA_AUTORECONF += "-I ${S}/testcases/realtime/m4"
51EXTRA_OECONF = " --with-realtime-testsuite --with-open-posix-testsuite "
52# ltp network/rpc test cases ftbfs when libtirpc is found
53EXTRA_OECONF += " --without-tirpc "
54
55do_compile() {
56 oe_runmake HOSTCC="${CC_FOR_BUILD}" HOST_CFLAGS="${CFLAGS_FOR_BUILD}" HOST_LDFLAGS="${LDFLAGS_FOR_BUILD}"
57}
58
59do_install(){
60 install -d ${D}${prefix}/
61 oe_runmake DESTDIR=${D} SKIP_IDCHECK=1 install include-install
62
63 # fixup not deploy STPfailure_report.pl to avoid confusing about it fails to run
64 # as it lacks dependency on some perl moudle such as LWP::Simple
65 # And this script previously works as a tool for analyzing failures from LTP
66 # runs on the OSDL's Scaleable Test Platform (STP) and it mainly accesses
67 # http://khack.osdl.org to retrieve ltp test results run on
68 # OSDL's Scaleable Test Platform, but now http://khack.osdl.org unaccessible
69 rm -rf ${D}${prefix}/bin/STPfailure_report.pl
70
71 # Copy POSIX test suite into ${D}${prefix}/testcases by manual
72 cp -r testcases/open_posix_testsuite ${D}${prefix}/testcases
73
74 # Makefile were configured in the build system
75 find ${D}${prefix} -name Makefile | xargs -n 1 sed -i \
76 -e 's@[^ ]*-fdebug-prefix-map=[^ "]*@@g' \
77 -e 's@[^ ]*-fmacro-prefix-map=[^ "]*@@g' \
78 -e 's@[^ ]*-ffile-prefix-map=[^ "]*@@g' \
79 -e 's@[^ ]*--sysroot=[^ "]*@@g'
80
81 # The controllers memcg_stree test seems to cause us hangs and takes 900s
82 # (maybe we expect more regular output?), anyhow, skip it
83 sed -e '/^memcg_stress/d' -i ${D}${prefix}/runtest/controllers
Andrew Geissler615f2f12022-07-15 14:00:58 -050084
85 # We don't need to ship the compile logs that open_posix_testsuite writes
86 rm -f ${D}${prefix}/testcases/open_posix_testsuite/logfile.*
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000087}
88
89RDEPENDS:${PN} = "\
90 attr \
91 bash \
92 bc \
93 coreutils \
94 cpio \
95 cronie \
96 curl \
97 e2fsprogs \
98 e2fsprogs-mke2fs \
99 expect \
100 file \
101 gawk \
102 gdb \
103 gzip \
104 iproute2 \
105 ldd \
106 libaio \
107 logrotate \
108 net-tools \
109 perl \
110 python3-core \
111 procps \
112 quota \
113 unzip \
114 util-linux \
115 which \
116 tar \
117"
118
119FILES:${PN} += "${prefix}/* ${prefix}/runtest/* ${prefix}/scenario_groups/* ${prefix}/testcases/bin/* ${prefix}/testcases/bin/*/bin/* ${prefix}/testscripts/* ${prefix}/testcases/open_posix_testsuite/* ${prefix}/testcases/open_posix_testsuite/conformance/* ${prefix}/testcases/open_posix_testsuite/Documentation/* ${prefix}/testcases/open_posix_testsuite/functional/* ${prefix}/testcases/open_posix_testsuite/include/* ${prefix}/testcases/open_posix_testsuite/scripts/* ${prefix}/testcases/open_posix_testsuite/stress/* ${prefix}/testcases/open_posix_testsuite/tools/* ${prefix}/testcases/data/nm01/lib.a ${prefix}/lib/libmem.a"
120
121# Avoid stripping some generated binaries otherwise some of the ltp tests such as ldd01 & nm01 fail
122INHIBIT_PACKAGE_STRIP_FILES = "${prefix}/testcases/bin/nm01 ${prefix}/testcases/bin/ldd01"
123INSANE_SKIP:${PN} += "already-stripped staticdev"
124
125remove_broken_musl_sources() {
126 [ "${TCLIBC}" = "musl" ] || return 0
127
128 cd ${S}
129 echo "WARNING: remove unsupported tests (until they're fixed)"
130
131 # sync with upstream
132 # https://github.com/linux-test-project/ltp/blob/master/ci/alpine.sh#L33
133 rm -rfv \
134 testcases/kernel/syscalls/confstr/confstr01.c \
135 testcases/kernel/syscalls/fmtmsg/fmtmsg01.c \
136 testcases/kernel/syscalls/getcontext/getcontext01.c \
137 testcases/kernel/syscalls/rt_tgsigqueueinfo/rt_tgsigqueueinfo01.c \
138 testcases/kernel/syscalls/timer_create/timer_create01.c \
139 testcases/kernel/syscalls/timer_create/timer_create03.c \
140 utils/benchmark/ebizzy-0.3
141}
142do_patch[postfuncs] += "remove_broken_musl_sources"
143
144# Avoid file dependency scans, as LTP checks for things that may or may not
145# exist on the running system. For instance it has specific checks for
146# csh and ksh which are not typically part of OpenEmbedded systems (but
147# can be added via additional layers.)
148SKIP_FILEDEPS:${PN} = '1'