blob: 150eca927470ecb81b709537355b7421df751bc9 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Documentation generator for glib-based software"
2DESCRIPTION = "Gtk-doc is a set of scripts that extract specially formatted comments \
3 from glib-based software and produce a set of html documentation files from them"
Andrew Geissler6ce62a22020-11-30 19:58:47 -06004HOMEPAGE = "https://www.gtk.org/docs/"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00005LICENSE = "GPL-2.0-only"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08006LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
7
8inherit gnomebase
9
10# Configure the scripts correctly (and build their dependencies) only if they are actually
11# going to be used; otheriwse we need only the m4/makefile includes from the gtk-doc tarball.
12PACKAGECONFIG ??= "${@bb.utils.contains("DISTRO_FEATURES", "api-documentation", "working-scripts", "", d)}"
13
14# This will cause target gtk-doc to hardcode paths of native dependencies
15# into its scripts. This means that target gtk-doc package is broken;
16# hopefully no one minds because its scripts are not used for anything during build
17# and shouldn't be used on targets.
Brad Bishop15ae2502019-06-18 21:44:24 -040018PACKAGECONFIG[working-scripts] = ",,libxslt-native xmlto-native python3-six python3-pygments"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080019PACKAGECONFIG[tests] = "--enable-tests,--disable-tests,glib-2.0"
20
Andrew Geissler615f2f12022-07-15 14:00:58 -050021CACHED_CONFIGUREVARS += "ac_cv_path_XSLTPROC=xsltproc"
22
Andrew Geisslerd1e89492021-02-12 15:35:20 -060023SRC_URI[archive.sha256sum] = "cc1b709a20eb030a278a1f9842a362e00402b7f834ae1df4c1998a723152bf43"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080024SRC_URI += "file://0001-Do-not-hardocode-paths-to-perl-python-in-scripts.patch \
25 file://0001-Do-not-error-out-if-xsltproc-is-not-found.patch \
26 file://conditionaltests.patch \
27 file://no-clobber.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080028 "
Patrick Williams213cb262021-08-07 19:21:33 -050029SRC_URI:append:class-native = " file://pkg-config-native.patch"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080030
31BBCLASSEXTEND = "native nativesdk"
32
33# Do not check for XML catalogs when building because that
34# information is not used for anything during build. Recipe
35# dependencies make sure we have all the right bits.
Patrick Williams213cb262021-08-07 19:21:33 -050036do_configure:prepend() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080037 sed -i -e 's,^JH_CHECK_XML_CATALOG.*,,' ${S}/configure.ac
38}
39
Patrick Williams213cb262021-08-07 19:21:33 -050040do_install:append () {
Andrew Geissler82c905d2020-04-13 13:39:40 -050041 # configure values for python3 and pkg-config encoded in scripts
42 for fn in ${bindir}/gtkdoc-depscan \
43 ${bindir}/gtkdoc-mkhtml2 \
Andrew Geissler90fd73c2021-03-05 15:25:55 -060044 ${datadir}/gtk-doc/python/gtkdoc/config_data.py \
Andrew Geissler4ed12e12020-06-05 18:00:41 -050045 ${datadir}/gtk-doc/python/gtkdoc/config.py; do
Andrew Geissler82c905d2020-04-13 13:39:40 -050046 sed -e 's,${RECIPE_SYSROOT_NATIVE}/usr/bin/pkg-config,${bindir}/pkg-config,' \
47 -e 's,${HOSTTOOLS_DIR}/python3,${bindir}/python3,' \
Andrew Geissler615f2f12022-07-15 14:00:58 -050048 -e '1s|^#!.*|#!/usr/bin/env python3|' \
Andrew Geissler82c905d2020-04-13 13:39:40 -050049 -i ${D}$fn
50 done
51}
52
Patrick Williams213cb262021-08-07 19:21:33 -050053FILES:${PN} += "${datadir}/sgml"
54FILES:${PN}-doc = ""
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080055
Patrick Williams213cb262021-08-07 19:21:33 -050056SYSROOT_PREPROCESS_FUNCS:append:class-native = " gtkdoc_makefiles_sysroot_preprocess"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080057gtkdoc_makefiles_sysroot_preprocess() {
58 # Patch the gtk-doc makefiles so that the qemu wrapper is used to run transient binaries
59 # instead of libtool wrapper or running them directly
60 sed -i \
61 -e "s|GTKDOC_RUN =.*|GTKDOC_RUN = \$(top_builddir)/gtkdoc-qemuwrapper|" \
62 ${SYSROOT_DESTDIR}${datadir}/gtk-doc/data/gtk-doc*make
63}