blob: ec04c1d3843467659a81a6ae731c8ed0fbff0342 [file] [log] [blame]
Andrew Geissler95ac1b82021-03-31 14:34:31 -05001# To allow util-linux to optionally build-depend on cryptsetup, libuuid is
2# split out of the main recipe, as it's needed by cryptsetup
3
4require util-linux.inc
5
6inherit autotools gettext pkgconfig
7
8S = "${WORKDIR}/util-linux-${PV}"
Patrick Williams705982a2024-01-12 09:51:57 -06009
10EXTRA_AUTORECONF += "--exclude=gtkdocize"
Andrew Geissler95ac1b82021-03-31 14:34:31 -050011EXTRA_OECONF += "--disable-all-programs --enable-libuuid"
Patrick Williams705982a2024-01-12 09:51:57 -060012
Andrew Geissler95ac1b82021-03-31 14:34:31 -050013LICENSE = "BSD-3-Clause"
14
Patrick Williams213cb262021-08-07 19:21:33 -050015do_install:append() {
Andrew Geissler95ac1b82021-03-31 14:34:31 -050016 rm -rf ${D}${datadir} ${D}${bindir} ${D}${base_bindir} ${D}${sbindir} ${D}${base_sbindir} ${D}${exec_prefix}/sbin
17}
18
19BBCLASSEXTEND = "native nativesdk"