blob: 7394385d30b0dca0bd57b125ab95c27987a717b2 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001BPN = "qemu"
2
3require qemu-native.inc
4
Brad Bishopc68388fc2019-08-26 01:33:31 -04005# As some of the files installed by qemu-native and qemu-system-native
Brad Bishopc342db32019-05-15 21:57:59 -04006# are the same, we depend on qemu-native to get the full installation set
7# and avoid file clashes
Brad Bishop15ae2502019-06-18 21:44:24 -04008DEPENDS = "glib-2.0-native zlib-native pixman-native qemu-native bison-native"
Brad Bishopc342db32019-05-15 21:57:59 -04009
10EXTRA_OECONF_append = " --target-list=${@get_qemu_system_target_list(d)}"
11
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050012PACKAGECONFIG ??= "fdt alsa kvm \
13 ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'virglrenderer glx', '' ,d)} \
14"
Brad Bishopc342db32019-05-15 21:57:59 -040015
16# Handle distros such as CentOS 5 32-bit that do not have kvm support
17PACKAGECONFIG_remove = "${@'kvm' if not os.path.exists('/usr/include/linux/kvm.h') else ''}"
18
19do_install_append() {
20 install -Dm 0755 ${WORKDIR}/powerpc_rom.bin ${D}${datadir}/qemu
21
22 # The following is also installed by qemu-native
23 rm -f ${D}${datadir}/qemu/trace-events-all
24 rm -rf ${D}${datadir}/qemu/keymaps
25 rm -rf ${D}${datadir}/icons/
26}