blob: 36f2a07ecfa446cf3b1de013b69d7ee7a5843e4d [file] [log] [blame]
Patrick Williams8e7b46e2023-05-01 14:19:06 -05001SUMMARY = "Provides API for encoding/decoding of data to/from D-Bus wire format"
2DESCRIPTION = "This crate provides API for encoding/decoding of data to/from D-Bus wire format.\
3This binary wire format is simple and very efficient and hence useful outside of D-Bus context as well.\
4A modified form of this format, GVariant is very commonly used for efficient storage of arbitrary \
5data and is also supported by this crate."
6HOMEPAGE = "https://gitlab.freedesktop.org/dbus/zbus/"
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=b377b220f43d747efdec40d69fcaa69d"
9
Andrew Geissler028142b2023-05-05 11:29:21 -050010DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'glib-2.0', '', d)}"
11
Patrick Williams8e7b46e2023-05-01 14:19:06 -050012SRC_URI = " \
13 git://gitlab.freedesktop.org/dbus/zbus;protocol=https;branch=main;subpath=zvariant \
14 file://0001-Tweak-zvariant-crate-config.patch;striplevel=2 \
15"
16
17SRCREV = "07506776fab5f58e029760bb4b288f670c7eecd6"
18S = "${WORKDIR}/zvariant"
19
20python do_clean_lic_file_symlink() {
21 bb.utils.remove("LICENCE")
22}
23
24addtask clean_lic_file_symlink after do_unpack before do_patch
25
Andrew Geissler028142b2023-05-05 11:29:21 -050026inherit ptest-cargo pkgconfig cargo-update-recipe-crates
Patrick Williams8e7b46e2023-05-01 14:19:06 -050027
28# Remove this when the recipe is reproducible
29EXCLUDE_FROM_WORLD = "1"
30
31require ${BPN}-crates.inc
32require ${BPN}-git-crates.inc
Andrew Geissler028142b2023-05-05 11:29:21 -050033
34# zvariant is an indermediate product for the zbus project
35# and so, it provided only a static lib (rlib) which fall only
36# in -dev package
37ALLOW_EMPTY:${PN} = "1"