Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Utilities for managing LZMA compressed files" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 2 | HOMEPAGE = "https://tukaani.org/xz/" |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 3 | DESCRIPTION = "XZ Utils is free general-purpose data compression software with a high compression ratio. XZ Utils were written for POSIX-like systems, but also work on some not-so-POSIX systems. XZ Utils are the successor to LZMA Utils." |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 4 | SECTION = "base" |
| 5 | |
| 6 | # The source includes bits of PD, GPLv2, GPLv3, LGPLv2.1+, but the only file |
| 7 | # which is GPLv3 is an m4 macro which isn't shipped in any of our packages, |
| 8 | # and the LGPL bits are under lib/, which appears to be used for libgnu, which |
| 9 | # appears to be used for DOS builds. So we're left with GPLv2+ and PD. |
| 10 | LICENSE = "GPLv2+ & GPL-3.0-with-autoconf-exception & LGPLv2.1+ & PD" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 11 | LICENSE:${PN} = "GPLv2+" |
| 12 | LICENSE:${PN}-dev = "GPLv2+" |
| 13 | LICENSE:${PN}-staticdev = "GPLv2+" |
| 14 | LICENSE:${PN}-doc = "GPLv2+" |
| 15 | LICENSE:${PN}-dbg = "GPLv2+" |
| 16 | LICENSE:${PN}-locale = "GPLv2+" |
| 17 | LICENSE:liblzma = "PD" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 18 | |
| 19 | LIC_FILES_CHKSUM = "file://COPYING;md5=97d554a32881fee0aa283d96e47cb24a \ |
| 20 | file://COPYING.GPLv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 21 | file://COPYING.GPLv3;md5=d32239bcb673463ab874e80d47fae504 \ |
| 22 | file://COPYING.LGPLv2.1;md5=4fbd65380cdd255951079008b364516c \ |
| 23 | file://lib/getopt.c;endline=23;md5=2069b0ee710572c03bb3114e4532cd84 \ |
| 24 | " |
| 25 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 26 | SRC_URI = "https://tukaani.org/xz/xz-${PV}.tar.gz" |
Andrew Geissler | 1e34c2d | 2020-05-29 16:02:59 -0500 | [diff] [blame] | 27 | SRC_URI[md5sum] = "0d270c997aff29708c74d53f599ef717" |
| 28 | SRC_URI[sha256sum] = "f6f4910fd033078738bd82bfba4f49219d03b17eb0794eb91efbae419f4aba10" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 29 | UPSTREAM_CHECK_REGEX = "xz-(?P<pver>\d+(\.\d+)+)\.tar" |
| 30 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 31 | CACHED_CONFIGUREVARS += "gl_cv_posix_shell=/bin/sh" |
| 32 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 33 | inherit autotools gettext |
| 34 | |
| 35 | PACKAGES =+ "liblzma" |
| 36 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 37 | FILES:liblzma = "${libdir}/liblzma*${SOLIBS}" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 38 | |
| 39 | inherit update-alternatives |
| 40 | ALTERNATIVE_PRIORITY = "100" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 41 | ALTERNATIVE:${PN} = "xz xzcat unxz \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 42 | lzma lzcat unlzma" |
| 43 | |
| 44 | BBCLASSEXTEND = "native nativesdk" |