blob: de816bcec1d8d44c195f80999a89843d8b18ec74 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001#
2# This class knows how to package up [e]glibc. Its shared since prebuild binary toolchains
3# may need packaging and its pointless to duplicate this code.
4#
5# Caller should set GLIBC_INTERNAL_USE_BINARY_LOCALE to one of:
6# "compile" - Use QEMU to generate the binary locale files
7# "precompiled" - The binary locale files are pregenerated and already present
8# "ondevice" - The device will build the locale files upon first boot through the postinst
9
10GLIBC_INTERNAL_USE_BINARY_LOCALE ?= "ondevice"
11
Brad Bishop6e60e8b2018-02-01 10:27:11 -050012GLIBC_SPLIT_LC_PACKAGES ?= "0"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050013
Brad Bishop6e60e8b2018-02-01 10:27:11 -050014python __anonymous () {
15 enabled = d.getVar("ENABLE_BINARY_LOCALE_GENERATION")
16
17 pn = d.getVar("PN")
Patrick Williamsc124f4f2015-09-15 14:41:29 -050018 if pn.endswith("-initial"):
19 enabled = False
20
21 if enabled and int(enabled):
22 import re
23
Brad Bishop6e60e8b2018-02-01 10:27:11 -050024 target_arch = d.getVar("TARGET_ARCH")
25 binary_arches = d.getVar("BINARY_LOCALE_ARCHES") or ""
26 use_cross_localedef = d.getVar("LOCALE_GENERATION_WITH_CROSS-LOCALEDEF") or ""
Patrick Williamsc124f4f2015-09-15 14:41:29 -050027
28 for regexp in binary_arches.split(" "):
29 r = re.compile(regexp)
30
31 if r.match(target_arch):
Brad Bishop6e60e8b2018-02-01 10:27:11 -050032 depends = d.getVar("DEPENDS")
Patrick Williamsc124f4f2015-09-15 14:41:29 -050033 if use_cross_localedef == "1" :
34 depends = "%s cross-localedef-native" % depends
35 else:
36 depends = "%s qemu-native" % depends
37 d.setVar("DEPENDS", depends)
38 d.setVar("GLIBC_INTERNAL_USE_BINARY_LOCALE", "compile")
39 break
Patrick Williamsc124f4f2015-09-15 14:41:29 -050040}
41
Brad Bishop19323692019-04-05 15:28:33 -040042# try to fix disable charsets/locales/locale-code compile fail
43PACKAGE_NO_GCONV ?= "0"
44
Patrick Williamsc124f4f2015-09-15 14:41:29 -050045OVERRIDES_append = ":${TARGET_ARCH}-${TARGET_OS}"
46
Brad Bishopa5c52ff2018-11-23 10:55:50 +130047locale_base_postinst_ontarget() {
Patrick Williamsc0f7c042017-02-23 20:41:17 -060048localedef --inputfile=${datadir}/i18n/locales/%s --charmap=%s %s
Patrick Williamsc124f4f2015-09-15 14:41:29 -050049}
50
Patrick Williamsc124f4f2015-09-15 14:41:29 -050051locale_base_postrm() {
52#!/bin/sh
Patrick Williamsc0f7c042017-02-23 20:41:17 -060053localedef --delete-from-archive --inputfile=${datadir}/locales/%s --charmap=%s %s
Patrick Williamsc124f4f2015-09-15 14:41:29 -050054}
55
Patrick Williamsc124f4f2015-09-15 14:41:29 -050056LOCALETREESRC ?= "${PKGD}"
57
58do_prep_locale_tree() {
59 treedir=${WORKDIR}/locale-tree
60 rm -rf $treedir
61 mkdir -p $treedir/${base_bindir} $treedir/${base_libdir} $treedir/${datadir} $treedir/${localedir}
62 tar -cf - -C ${LOCALETREESRC}${datadir} -p i18n | tar -xf - -C $treedir/${datadir}
63 # unzip to avoid parsing errors
64 for i in $treedir/${datadir}/i18n/charmaps/*gz; do
65 gunzip $i
66 done
Brad Bishop19323692019-04-05 15:28:33 -040067 # The extract pattern "./l*.so*" is carefully selected so that it will
68 # match ld*.so and lib*.so*, but not any files in the gconv directory
69 # (if it exists). This makes sure we only unpack the files we need.
70 # This is important in case usrmerge is set in DISTRO_FEATURES, which
71 # means ${base_libdir} == ${libdir}.
72 tar -cf - -C ${LOCALETREESRC}${base_libdir} -p . | tar -xf - -C $treedir/${base_libdir} --wildcards './l*.so*'
73 if [ -f ${STAGING_LIBDIR_NATIVE}/libgcc_s.* ]; then
74 tar -cf - -C ${STAGING_LIBDIR_NATIVE} -p libgcc_s.* | tar -xf - -C $treedir/${base_libdir}
Patrick Williamsc124f4f2015-09-15 14:41:29 -050075 fi
76 install -m 0755 ${LOCALETREESRC}${bindir}/localedef $treedir/${base_bindir}
77}
78
79do_collect_bins_from_locale_tree() {
80 treedir=${WORKDIR}/locale-tree
81
82 parent=$(dirname ${localedir})
83 mkdir -p ${PKGD}/$parent
84 tar -cf - -C $treedir/$parent -p $(basename ${localedir}) | tar -xf - -C ${PKGD}$parent
Brad Bishopc68388fc2019-08-26 01:33:31 -040085
86 # Finalize tree by chaning all duplicate files into hard links
87 cross-localedef-hardlink -c -v ${WORKDIR}/locale-tree
Patrick Williamsc124f4f2015-09-15 14:41:29 -050088}
89
90inherit qemu
91
92python package_do_split_gconvs () {
93 import re
Brad Bishop6e60e8b2018-02-01 10:27:11 -050094 if (d.getVar('PACKAGE_NO_GCONV') == '1'):
Patrick Williamsc124f4f2015-09-15 14:41:29 -050095 bb.note("package requested not splitting gconvs")
96 return
97
Brad Bishop6e60e8b2018-02-01 10:27:11 -050098 if not d.getVar('PACKAGES'):
Patrick Williamsc124f4f2015-09-15 14:41:29 -050099 return
100
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500101 mlprefix = d.getVar("MLPREFIX") or ""
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500102
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500103 bpn = d.getVar('BPN')
104 libdir = d.getVar('libdir')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500105 if not libdir:
106 bb.error("libdir not defined")
107 return
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500108 datadir = d.getVar('datadir')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500109 if not datadir:
110 bb.error("datadir not defined")
111 return
112
Brad Bishop316dfdd2018-06-25 12:45:53 -0400113 gconv_libdir = oe.path.join(libdir, "gconv")
114 charmap_dir = oe.path.join(datadir, "i18n", "charmaps")
115 locales_dir = oe.path.join(datadir, "i18n", "locales")
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500116 binary_locales_dir = d.getVar('localedir')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500117
118 def calc_gconv_deps(fn, pkg, file_regex, output_pattern, group):
119 deps = []
120 f = open(fn, "rb")
Brad Bishop19323692019-04-05 15:28:33 -0400121 c_re = re.compile(r'^copy "(.*)"')
122 i_re = re.compile(r'^include "(\w+)".*')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500123 for l in f.readlines():
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600124 l = l.decode("latin-1")
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500125 m = c_re.match(l) or i_re.match(l)
126 if m:
127 dp = legitimize_package_name('%s%s-gconv-%s' % (mlprefix, bpn, m.group(1)))
128 if not dp in deps:
129 deps.append(dp)
130 f.close()
131 if deps != []:
132 d.setVar('RDEPENDS_%s' % pkg, " ".join(deps))
133 if bpn != 'glibc':
134 d.setVar('RPROVIDES_%s' % pkg, pkg.replace(bpn, 'glibc'))
135
Brad Bishop19323692019-04-05 15:28:33 -0400136 do_split_packages(d, gconv_libdir, file_regex=r'^(.*)\.so$', output_pattern=bpn+'-gconv-%s', \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500137 description='gconv module for character set %s', hook=calc_gconv_deps, \
138 extra_depends=bpn+'-gconv')
139
140 def calc_charmap_deps(fn, pkg, file_regex, output_pattern, group):
141 deps = []
142 f = open(fn, "rb")
Brad Bishop19323692019-04-05 15:28:33 -0400143 c_re = re.compile(r'^copy "(.*)"')
144 i_re = re.compile(r'^include "(\w+)".*')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500145 for l in f.readlines():
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600146 l = l.decode("latin-1")
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500147 m = c_re.match(l) or i_re.match(l)
148 if m:
149 dp = legitimize_package_name('%s%s-charmap-%s' % (mlprefix, bpn, m.group(1)))
150 if not dp in deps:
151 deps.append(dp)
152 f.close()
153 if deps != []:
154 d.setVar('RDEPENDS_%s' % pkg, " ".join(deps))
155 if bpn != 'glibc':
156 d.setVar('RPROVIDES_%s' % pkg, pkg.replace(bpn, 'glibc'))
157
Brad Bishop19323692019-04-05 15:28:33 -0400158 do_split_packages(d, charmap_dir, file_regex=r'^(.*)\.gz$', output_pattern=bpn+'-charmap-%s', \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500159 description='character map for %s encoding', hook=calc_charmap_deps, extra_depends='')
160
161 def calc_locale_deps(fn, pkg, file_regex, output_pattern, group):
162 deps = []
163 f = open(fn, "rb")
Brad Bishop19323692019-04-05 15:28:33 -0400164 c_re = re.compile(r'^copy "(.*)"')
165 i_re = re.compile(r'^include "(\w+)".*')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500166 for l in f.readlines():
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600167 l = l.decode("latin-1")
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500168 m = c_re.match(l) or i_re.match(l)
169 if m:
170 dp = legitimize_package_name(mlprefix+bpn+'-localedata-%s' % m.group(1))
171 if not dp in deps:
172 deps.append(dp)
173 f.close()
174 if deps != []:
175 d.setVar('RDEPENDS_%s' % pkg, " ".join(deps))
176 if bpn != 'glibc':
177 d.setVar('RPROVIDES_%s' % pkg, pkg.replace(bpn, 'glibc'))
178
Brad Bishop19323692019-04-05 15:28:33 -0400179 do_split_packages(d, locales_dir, file_regex=r'(.*)', output_pattern=bpn+'-localedata-%s', \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500180 description='locale definition for %s', hook=calc_locale_deps, extra_depends='')
181 d.setVar('PACKAGES', d.getVar('PACKAGES', False) + ' ' + d.getVar('MLPREFIX', False) + bpn + '-gconv')
182
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500183 use_bin = d.getVar("GLIBC_INTERNAL_USE_BINARY_LOCALE")
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500184
Brad Bishop19323692019-04-05 15:28:33 -0400185 dot_re = re.compile(r"(.*)\.(.*)")
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500186
187 # Read in supported locales and associated encodings
188 supported = {}
Brad Bishop316dfdd2018-06-25 12:45:53 -0400189 with open(oe.path.join(d.getVar('WORKDIR'), "SUPPORTED")) as f:
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500190 for line in f.readlines():
191 try:
192 locale, charset = line.rstrip().split()
193 except ValueError:
194 continue
195 supported[locale] = charset
196
197 # GLIBC_GENERATE_LOCALES var specifies which locales to be generated. empty or "all" means all locales
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500198 to_generate = d.getVar('GLIBC_GENERATE_LOCALES')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500199 if not to_generate or to_generate == 'all':
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600200 to_generate = sorted(supported.keys())
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500201 else:
202 to_generate = to_generate.split()
203 for locale in to_generate:
204 if locale not in supported:
205 if '.' in locale:
206 charset = locale.split('.')[1]
207 else:
208 charset = 'UTF-8'
209 bb.warn("Unsupported locale '%s', assuming encoding '%s'" % (locale, charset))
210 supported[locale] = charset
211
212 def output_locale_source(name, pkgname, locale, encoding):
Patrick Williamsf1e5d692016-03-30 15:21:19 -0500213 d.setVar('RDEPENDS_%s' % pkgname, '%slocaledef %s-localedata-%s %s-charmap-%s' % \
214 (mlprefix, mlprefix+bpn, legitimize_package_name(locale), mlprefix+bpn, legitimize_package_name(encoding)))
Brad Bishopa5c52ff2018-11-23 10:55:50 +1300215 d.setVar('pkg_postinst_ontarget_%s' % pkgname, d.getVar('locale_base_postinst_ontarget') \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500216 % (locale, encoding, locale))
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500217 d.setVar('pkg_postrm_%s' % pkgname, d.getVar('locale_base_postrm') % \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500218 (locale, encoding, locale))
219
220 def output_locale_binary_rdepends(name, pkgname, locale, encoding):
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500221 dep = legitimize_package_name('%s-binary-localedata-%s' % (bpn, name))
222 lcsplit = d.getVar('GLIBC_SPLIT_LC_PACKAGES')
223 if lcsplit and int(lcsplit):
224 d.appendVar('PACKAGES', ' ' + dep)
225 d.setVar('ALLOW_EMPTY_%s' % dep, '1')
226 d.setVar('RDEPENDS_%s' % pkgname, mlprefix + dep)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500227
228 commands = {}
229
230 def output_locale_binary(name, pkgname, locale, encoding):
Brad Bishop316dfdd2018-06-25 12:45:53 -0400231 treedir = oe.path.join(d.getVar("WORKDIR"), "locale-tree")
232 ldlibdir = oe.path.join(treedir, d.getVar("base_libdir"))
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500233 path = d.getVar("PATH")
Brad Bishop316dfdd2018-06-25 12:45:53 -0400234 i18npath = oe.path.join(treedir, datadir, "i18n")
235 gconvpath = oe.path.join(treedir, "iconvdata")
236 outputpath = oe.path.join(treedir, binary_locales_dir)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500237
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500238 use_cross_localedef = d.getVar("LOCALE_GENERATION_WITH_CROSS-LOCALEDEF") or "0"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500239 if use_cross_localedef == "1":
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500240 target_arch = d.getVar('TARGET_ARCH')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500241 locale_arch_options = { \
Brad Bishop19323692019-04-05 15:28:33 -0400242 "arc": " --uint32-align=4 --little-endian ", \
243 "arceb": " --uint32-align=4 --big-endian ", \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500244 "arm": " --uint32-align=4 --little-endian ", \
245 "armeb": " --uint32-align=4 --big-endian ", \
246 "aarch64": " --uint32-align=4 --little-endian ", \
247 "aarch64_be": " --uint32-align=4 --big-endian ", \
248 "sh4": " --uint32-align=4 --big-endian ", \
249 "powerpc": " --uint32-align=4 --big-endian ", \
250 "powerpc64": " --uint32-align=4 --big-endian ", \
251 "mips": " --uint32-align=4 --big-endian ", \
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600252 "mipsisa32r6": " --uint32-align=4 --big-endian ", \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500253 "mips64": " --uint32-align=4 --big-endian ", \
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600254 "mipsisa64r6": " --uint32-align=4 --big-endian ", \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500255 "mipsel": " --uint32-align=4 --little-endian ", \
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600256 "mipsisa32r6el": " --uint32-align=4 --little-endian ", \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500257 "mips64el":" --uint32-align=4 --little-endian ", \
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600258 "mipsisa64r6el":" --uint32-align=4 --little-endian ", \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800259 "riscv64": " --uint32-align=4 --little-endian ", \
260 "riscv32": " --uint32-align=4 --little-endian ", \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500261 "i586": " --uint32-align=4 --little-endian ", \
262 "i686": " --uint32-align=4 --little-endian ", \
263 "x86_64": " --uint32-align=4 --little-endian " }
264
265 if target_arch in locale_arch_options:
266 localedef_opts = locale_arch_options[target_arch]
267 else:
268 bb.error("locale_arch_options not found for target_arch=" + target_arch)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600269 bb.fatal("unknown arch:" + target_arch + " for locale_arch_options")
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500270
Brad Bishopc68388fc2019-08-26 01:33:31 -0400271 localedef_opts += " --force --no-hard-links --no-archive --prefix=%s \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500272 --inputfile=%s/%s/i18n/locales/%s --charmap=%s %s/%s" \
273 % (treedir, treedir, datadir, locale, encoding, outputpath, name)
274
275 cmd = "PATH=\"%s\" I18NPATH=\"%s\" GCONV_PATH=\"%s\" cross-localedef %s" % \
276 (path, i18npath, gconvpath, localedef_opts)
277 else: # earlier slower qemu way
278 qemu = qemu_target_binary(d)
Brad Bishopc68388fc2019-08-26 01:33:31 -0400279 localedef_opts = "--force --no-hard-links --no-archive --prefix=%s \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500280 --inputfile=%s/i18n/locales/%s --charmap=%s %s" \
281 % (treedir, datadir, locale, encoding, name)
282
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500283 qemu_options = d.getVar('QEMU_OPTIONS')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500284
285 cmd = "PSEUDO_RELOADED=YES PATH=\"%s\" I18NPATH=\"%s\" %s -L %s \
Brad Bishop19323692019-04-05 15:28:33 -0400286 -E LD_LIBRARY_PATH=%s %s %s${base_bindir}/localedef %s" % \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500287 (path, i18npath, qemu, treedir, ldlibdir, qemu_options, treedir, localedef_opts)
288
289 commands["%s/%s" % (outputpath, name)] = cmd
290
291 bb.note("generating locale %s (%s)" % (locale, encoding))
292
293 def output_locale(name, locale, encoding):
294 pkgname = d.getVar('MLPREFIX', False) + 'locale-base-' + legitimize_package_name(name)
295 d.setVar('ALLOW_EMPTY_%s' % pkgname, '1')
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500296 d.setVar('PACKAGES', '%s %s' % (pkgname, d.getVar('PACKAGES')))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500297 rprovides = ' %svirtual-locale-%s' % (mlprefix, legitimize_package_name(name))
Brad Bishop19323692019-04-05 15:28:33 -0400298 m = re.match(r"(.*)_(.*)", name)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500299 if m:
300 rprovides += ' %svirtual-locale-%s' % (mlprefix, m.group(1))
301 d.setVar('RPROVIDES_%s' % pkgname, rprovides)
302
303 if use_bin == "compile":
304 output_locale_binary_rdepends(name, pkgname, locale, encoding)
305 output_locale_binary(name, pkgname, locale, encoding)
306 elif use_bin == "precompiled":
307 output_locale_binary_rdepends(name, pkgname, locale, encoding)
308 else:
309 output_locale_source(name, pkgname, locale, encoding)
310
311 if use_bin == "compile":
312 bb.note("preparing tree for binary locale generation")
313 bb.build.exec_func("do_prep_locale_tree", d)
314
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500315 utf8_only = int(d.getVar('LOCALE_UTF8_ONLY') or 0)
316 utf8_is_default = int(d.getVar('LOCALE_UTF8_IS_DEFAULT') or 0)
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500317
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500318 encodings = {}
319 for locale in to_generate:
320 charset = supported[locale]
321 if utf8_only and charset != 'UTF-8':
322 continue
323
324 m = dot_re.match(locale)
325 if m:
326 base = m.group(1)
327 else:
328 base = locale
329
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500330 # Non-precompiled locales may be renamed so that the default
331 # (non-suffixed) encoding is always UTF-8, i.e., instead of en_US and
332 # en_US.UTF-8, we have en_US and en_US.ISO-8859-1. This implicitly
333 # contradicts SUPPORTED.
334 if use_bin == "precompiled" or not utf8_is_default:
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500335 output_locale(locale, base, charset)
336 else:
337 if charset == 'UTF-8':
338 output_locale(base, base, charset)
339 else:
340 output_locale('%s.%s' % (base, charset), base, charset)
341
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500342 def metapkg_hook(file, pkg, pattern, format, basename):
343 name = basename.split('/', 1)[0]
344 metapkg = legitimize_package_name('%s-binary-localedata-%s' % (mlprefix+bpn, name))
345 d.appendVar('RDEPENDS_%s' % metapkg, ' ' + pkg)
346
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500347 if use_bin == "compile":
Brad Bishop316dfdd2018-06-25 12:45:53 -0400348 makefile = oe.path.join(d.getVar("WORKDIR"), "locale-tree", "Makefile")
Brad Bishop64c979e2019-11-04 13:55:29 -0500349 with open(makefile, "w") as m:
350 m.write("all: %s\n\n" % " ".join(commands.keys()))
351 total = len(commands)
352 for i, (maketarget, makerecipe) in enumerate(commands.items()):
353 m.write(maketarget + ":\n")
354 m.write("\t@echo 'Progress %d/%d'\n" % (i, total))
355 m.write("\t" + makerecipe + "\n\n")
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500356 d.setVar("EXTRA_OEMAKE", "-C %s ${PARALLEL_MAKE}" % (os.path.dirname(makefile)))
Brad Bishop19323692019-04-05 15:28:33 -0400357 d.setVarFlag("oe_runmake", "progress", "outof:Progress\s(\d+)/(\d+)")
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500358 bb.note("Executing binary locale generation makefile")
359 bb.build.exec_func("oe_runmake", d)
360 bb.note("collecting binary locales from locale tree")
361 bb.build.exec_func("do_collect_bins_from_locale_tree", d)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500362
363 if use_bin in ('compile', 'precompiled'):
364 lcsplit = d.getVar('GLIBC_SPLIT_LC_PACKAGES')
365 if lcsplit and int(lcsplit):
Brad Bishop19323692019-04-05 15:28:33 -0400366 do_split_packages(d, binary_locales_dir, file_regex=r'^(.*/LC_\w+)', \
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500367 output_pattern=bpn+'-binary-localedata-%s', \
368 description='binary locale definition for %s', recursive=True,
369 hook=metapkg_hook, extra_depends='', allow_dirs=True, match_path=True)
370 else:
Brad Bishop19323692019-04-05 15:28:33 -0400371 do_split_packages(d, binary_locales_dir, file_regex=r'(.*)', \
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500372 output_pattern=bpn+'-binary-localedata-%s', \
373 description='binary locale definition for %s', extra_depends='', allow_dirs=True)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500374 else:
375 bb.note("generation of binary locales disabled. this may break i18n!")
376
377}
378
379# We want to do this indirection so that we can safely 'return'
380# from the called function even though we're prepending
381python populate_packages_prepend () {
382 bb.build.exec_func('package_do_split_gconvs', d)
383}