blob: b8466d4833d29b066c87d544913009901aa9bdaa [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "GNOME configuration system"
Brad Bishop64c979e2019-11-04 13:55:29 -05002DESCRIPTION = "GConf is a system for storing application preferences. \
3It is intended for user preferences; not configuration of something like \
4Apache, or arbitrary data storage."
Patrick Williamsc124f4f2015-09-15 14:41:29 -05005SECTION = "x11/gnome"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05006HOMEPAGE = "https://projects.gnome.org/gconf/"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05007LICENSE = "LGPLv2+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605"
9
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050010DEPENDS = "glib-2.0 dbus dbus-glib libxml2 intltool-native"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050011
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050012inherit gnomebase gtk-doc gettext gobject-introspection gio-module-cache
Patrick Williamsc124f4f2015-09-15 14:41:29 -050013
14SRC_URI = "${GNOME_MIRROR}/GConf/${@gnome_verdir("${PV}")}/GConf-${PV}.tar.xz;name=archive \
15 file://remove_plus_from_invalid_characters_list.patch \
16 file://unable-connect-dbus.patch \
Brad Bishop316dfdd2018-06-25 12:45:53 -040017 file://create_config_directory.patch \
Patrick Williamsc124f4f2015-09-15 14:41:29 -050018"
19
20SRC_URI[archive.md5sum] = "2b16996d0e4b112856ee5c59130e822c"
21SRC_URI[archive.sha256sum] = "1912b91803ab09a5eed34d364bf09fe3a2a9c96751fde03a4e0cfa51a04d784c"
22
23S = "${WORKDIR}/GConf-${PV}"
24
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050025EXTRA_OECONF = "--enable-shared --disable-static \
26 --disable-orbit --with-openldap=no --disable-gtk"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050027
Brad Bishop19323692019-04-05 15:28:33 -040028PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'polkit', d)}"
29# We really don't want Polkit for native
Patrick Williamsc124f4f2015-09-15 14:41:29 -050030PACKAGECONFIG_class-native = ""
Patrick Williamsc124f4f2015-09-15 14:41:29 -050031
Brad Bishop19323692019-04-05 15:28:33 -040032PACKAGECONFIG[polkit] = "--enable-defaults-service,--disable-defaults-service,polkit"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050033PACKAGECONFIG[debug] = "--enable-debug=yes, --enable-debug=minimum"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050034
35do_install_append() {
36 # this directory need to be created to avoid an Error 256 at gdm launch
37 install -d ${D}${sysconfdir}/gconf/gconf.xml.system
38
39 # this stuff is unusable
40 rm -f ${D}${libdir}/GConf/*/*.*a
41 rm -f ${D}${libdir}/gio/*/*.*a
42}
43
44do_install_append_class-native() {
45 create_wrapper ${D}/${bindir}/gconftool-2 \
46 GCONF_BACKEND_DIR=${STAGING_LIBDIR_NATIVE}/GConf/2
47}
48
Patrick Williamsc124f4f2015-09-15 14:41:29 -050049FILES_${PN} += "${libdir}/GConf/* \
50 ${libdir}/gio/*/*.so \
51 ${datadir}/polkit* \
52 ${datadir}/dbus-1/services/*.service \
53 ${datadir}/dbus-1/system-services/*.service \
54 "
Patrick Williamsc124f4f2015-09-15 14:41:29 -050055FILES_${PN}-dev += "${datadir}/sgml/gconf/gconf-1.0.dtd"
56
57BBCLASSEXTEND = "native"