blob: 5a950f183cb65cfe7884ef3c015adab7c9517373 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Python bindings for GStreamer 1.0"
2HOMEPAGE = "http://cgit.freedesktop.org/gstreamer/gst-python/"
3SECTION = "multimedia"
4
5LICENSE = "LGPLv2.1"
6LIC_FILES_CHKSUM = "file://COPYING;md5=c34deae4e395ca07e725ab0076a5f740"
7
Brad Bishop64c979e2019-11-04 13:55:29 -05008SRC_URI = "https://gstreamer.freedesktop.org/src/${PNREAL}/${PNREAL}-${PV}.tar.xz"
9SRC_URI[md5sum] = "499645fbd1790c5845c02a3998dccc1b"
10SRC_URI[sha256sum] = "b469c8955126f41b8ce0bf689b7029f182cd305f422b3a8df35b780bd8347489"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080011
12DEPENDS = "gstreamer1.0 python3-pygobject"
13RDEPENDS_${PN} += "gstreamer1.0 python3-pygobject"
14
15PNREAL = "gst-python"
16
17S = "${WORKDIR}/${PNREAL}-${PV}"
18
Brad Bishopc342db32019-05-15 21:57:59 -040019# gobject-introspection is mandatory and cannot be configured
20REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
21UNKNOWN_CONFIGURE_WHITELIST_append = " --enable-introspection --disable-introspection"
22
23inherit autotools pkgconfig distutils3-base upstream-version-is-even gobject-introspection distro_features_check
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080024
Brad Bishop15ae2502019-06-18 21:44:24 -040025EXTRA_OECONF += "--with-libpython-dir=${libdir}"
26
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080027do_install_append() {
Brad Bishop15ae2502019-06-18 21:44:24 -040028
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080029 # Note that this particular find line is taken from the Debian packaging for
30 # gst-python1.0.
31 find "${D}" \
32 -name '*.pyc' -o \
33 -name '*.pyo' -o \
34 -name '*.la' -o \
35 -name 'libgstpythonplugin*' \
36 -delete
37}