blob: 45302ef4f6a9012695997553bbf22b2ba37852c0 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "A library on top of GStreamer for building an RTSP server"
2HOMEPAGE = "http://cgit.freedesktop.org/gstreamer/gst-rtsp-server/"
3SECTION = "multimedia"
4LICENSE = "LGPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d"
6
7DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base"
8
9PNREAL = "gst-rtsp-server"
10
Brad Bishop64c979e2019-11-04 13:55:29 -050011SRC_URI = "https://gstreamer.freedesktop.org/src/${PNREAL}/${PNREAL}-${PV}.tar.xz \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080012 file://0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch \
13 file://gtk-doc-tweaks.patch \
14 "
15
Brad Bishop64c979e2019-11-04 13:55:29 -050016SRC_URI[md5sum] = "380d6a42e856c32fcefa508ad57129e0"
17SRC_URI[sha256sum] = "b0abacad2f86f60d63781d2b24443c5668733e8b08664bbef94124906d700144"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080018
19S = "${WORKDIR}/${PNREAL}-${PV}"
20
21inherit autotools pkgconfig upstream-version-is-even gobject-introspection gtk-doc
22
23EXTRA_OECONF = "--disable-examples --disable-tests"
24
25# Starting with 1.8.0 gst-rtsp-server includes dependency-less plugins as well
26LIBV = "1.0"
27require gst-plugins-package.inc
28
29delete_pkg_m4_file() {
30 # This m4 file is out of date and is missing PKG_CONFIG_SYSROOT_PATH tweaks which we need for introspection
31 rm "${S}/common/m4/pkg.m4" || true
32}
33
34do_configure[prefuncs] += " delete_pkg_m4_file"