blob: 5c008c53fed323eac5e226ca9d487110842ae4a5 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Provides support for the Tag Image File Format (TIFF)"
2LICENSE = "BSD-2-Clause"
3LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=34da3db46fab7501992f9615d7e158cf"
4
5CVE_PRODUCT = "libtiff"
6
7SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz \
Brad Bishop96ff1982019-08-19 13:50:42 -04008 file://CVE-2019-6128.patch \
Brad Bishop00e122a2019-10-05 11:10:57 -04009 file://CVE-2019-7663.patch \
10 file://CVE-2019-14973.patch \
Brad Bishop64c979e2019-11-04 13:55:29 -050011 file://CVE-2019-17546.patch \
Brad Bishop00e122a2019-10-05 11:10:57 -040012"
Brad Bishop19323692019-04-05 15:28:33 -040013SRC_URI[md5sum] = "114192d7ebe537912a2b97408832e7fd"
14SRC_URI[sha256sum] = "2c52d11ccaf767457db0c46795d9c7d1a8d8f76f68b0b800a3dfe45786b996e4"
15
16# exclude betas
17UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar"
18
19inherit autotools multilib_header
20
21CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no"
22
23PACKAGECONFIG ?= "cxx jpeg zlib lzma \
24 strip-chopping extrasample-as-alpha check-ycbcr-subsampling"
25
26PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,,"
27PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg,"
28PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
29PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz,"
30
31# Convert single-strip uncompressed images to multiple strips of specified
32# size (default: 8192) to reduce memory usage
33PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,,"
34
35# Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA
36PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,,"
37
38# Control picking up YCbCr subsample info. Disable to support files lacking
39# the tag
40PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,,"
41
42# Support a mechanism allowing reading large strips (usually one strip files)
43# in chunks when using TIFFReadScanline. Experimental 4.0+ feature
44PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,,"
45
46PACKAGES =+ "tiffxx tiff-utils"
47FILES_tiffxx = "${libdir}/libtiffxx.so.*"
48FILES_tiff-utils = "${bindir}/*"
49
50do_install_append() {
51 oe_multilib_header tiffconf.h
52}
53
54BBCLASSEXTEND = "native"