Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Error - Error/exception handling in an OO-ish way" |
| 2 | DESCRIPTION = "The Error package provides two interfaces. Firstly \ |
| 3 | Error provides a procedural interface to exception handling. \ |
| 4 | Secondly Error is a base class for errors/exceptions that can \ |
| 5 | either be thrown, for subsequent catch, or can simply be recorded." |
| 6 | HOMEPAGE = "https://github.com/shlomif/perl-error.pm" |
| 7 | SECTION = "libs" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 8 | LICENSE = "Artistic-1.0 | GPL-1.0-or-later" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 9 | |
| 10 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8f3499d09ee74a050c0319391ff9d100" |
| 11 | |
Andrew Geissler | d583833 | 2022-05-27 11:33:10 -0500 | [diff] [blame] | 12 | # remove at next version upgrade or when output changes |
| 13 | PR = "r1" |
| 14 | HASHEQUIV_HASH_VERSION .= ".1" |
| 15 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 16 | DEPENDS += "perl" |
| 17 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 18 | RDEPENDS:${PN} += " \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 19 | perl-module-carp \ |
| 20 | perl-module-exporter \ |
| 21 | perl-module-scalar-util \ |
| 22 | perl-module-overload \ |
| 23 | perl-module-strict \ |
| 24 | perl-module-vars \ |
| 25 | perl-module-warnings \ |
| 26 | " |
| 27 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 28 | RDEPENDS:${PN}-ptest += " \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 29 | perl-module-base \ |
| 30 | perl-module-file-spec \ |
| 31 | perl-module-io-handle \ |
| 32 | perl-module-ipc-open3 \ |
| 33 | perl-module-lib \ |
| 34 | perl-module-test-more \ |
| 35 | " |
| 36 | |
| 37 | SRC_URI = "http://cpan.metacpan.org/authors/id/S/SH/SHLOMIF/Error-${PV}.tar.gz" |
| 38 | |
| 39 | SRC_URI[md5sum] = "6732b1c6207e4a9a3e2987c88368039a" |
| 40 | SRC_URI[sha256sum] = "1a23f7913032aed6d4b68321373a3899ca66590f4727391a091ec19c95bf7adc" |
| 41 | |
| 42 | S = "${WORKDIR}/Error-${PV}" |
| 43 | |
| 44 | inherit cpan ptest-perl |
| 45 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 46 | do_install:prepend() { |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 47 | # test requires "-T" (taint) command line option |
| 48 | rm -rf ${B}/t/pod-coverage.t |
| 49 | } |
| 50 | |
| 51 | BBCLASSEXTEND = "native" |