blob: 40ff058ae13fbaca7d5b7ae7a707c36c59ddbd1a [file] [log] [blame]
Vijay Khemka66070d32020-07-23 15:22:56 -07001SUMMARY = "BMC Health Monitoring"
2DESCRIPTION = "Daemon to collect and monitor bmc health statistics"
3HOMEPAGE = "https://github.com/openbmc/phosphor-health-monitor"
4PR = "r1"
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=9e69ba356fa59848ffd865152a3ccc13"
7
8inherit meson pkgconfig
9inherit systemd
10
11DEPENDS += "sdbusplus"
12DEPENDS += "phosphor-dbus-interfaces"
13DEPENDS += "sdeventplus"
14DEPENDS += "phosphor-logging"
15DEPENDS += "nlohmann-json"
16
17SRC_URI = "git://github.com/openbmc/phosphor-health-monitor.git;protocol=git"
18SRCREV = "e279530e9232a8a5f61d8124628a16a901c5cef1"
19S = "${WORKDIR}/git"
20
21SYSTEMD_SERVICE_${PN} = "phosphor-health-monitor.service"