blob: 8859dad56656e9302fdadc1c53e9dac7efc15842 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001#
2# This class knows how to package up [e]glibc. Its shared since prebuild binary toolchains
3# may need packaging and its pointless to duplicate this code.
4#
5# Caller should set GLIBC_INTERNAL_USE_BINARY_LOCALE to one of:
6# "compile" - Use QEMU to generate the binary locale files
7# "precompiled" - The binary locale files are pregenerated and already present
8# "ondevice" - The device will build the locale files upon first boot through the postinst
9
10GLIBC_INTERNAL_USE_BINARY_LOCALE ?= "ondevice"
11
Brad Bishop6e60e8b2018-02-01 10:27:11 -050012GLIBC_SPLIT_LC_PACKAGES ?= "0"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050013
Brad Bishop6e60e8b2018-02-01 10:27:11 -050014python __anonymous () {
15 enabled = d.getVar("ENABLE_BINARY_LOCALE_GENERATION")
16
17 pn = d.getVar("PN")
Patrick Williamsc124f4f2015-09-15 14:41:29 -050018 if pn.endswith("-initial"):
19 enabled = False
20
21 if enabled and int(enabled):
22 import re
23
Brad Bishop6e60e8b2018-02-01 10:27:11 -050024 target_arch = d.getVar("TARGET_ARCH")
25 binary_arches = d.getVar("BINARY_LOCALE_ARCHES") or ""
26 use_cross_localedef = d.getVar("LOCALE_GENERATION_WITH_CROSS-LOCALEDEF") or ""
Patrick Williamsc124f4f2015-09-15 14:41:29 -050027
28 for regexp in binary_arches.split(" "):
29 r = re.compile(regexp)
30
31 if r.match(target_arch):
Brad Bishop6e60e8b2018-02-01 10:27:11 -050032 depends = d.getVar("DEPENDS")
Patrick Williamsc124f4f2015-09-15 14:41:29 -050033 if use_cross_localedef == "1" :
34 depends = "%s cross-localedef-native" % depends
35 else:
36 depends = "%s qemu-native" % depends
37 d.setVar("DEPENDS", depends)
38 d.setVar("GLIBC_INTERNAL_USE_BINARY_LOCALE", "compile")
39 break
Patrick Williamsc124f4f2015-09-15 14:41:29 -050040}
41
Brad Bishop19323692019-04-05 15:28:33 -040042# try to fix disable charsets/locales/locale-code compile fail
43PACKAGE_NO_GCONV ?= "0"
44
Patrick Williamsc124f4f2015-09-15 14:41:29 -050045OVERRIDES_append = ":${TARGET_ARCH}-${TARGET_OS}"
46
Brad Bishopa5c52ff2018-11-23 10:55:50 +130047locale_base_postinst_ontarget() {
Patrick Williamsc0f7c042017-02-23 20:41:17 -060048localedef --inputfile=${datadir}/i18n/locales/%s --charmap=%s %s
Patrick Williamsc124f4f2015-09-15 14:41:29 -050049}
50
Patrick Williamsc124f4f2015-09-15 14:41:29 -050051locale_base_postrm() {
52#!/bin/sh
Patrick Williamsc0f7c042017-02-23 20:41:17 -060053localedef --delete-from-archive --inputfile=${datadir}/locales/%s --charmap=%s %s
Patrick Williamsc124f4f2015-09-15 14:41:29 -050054}
55
Patrick Williamsc124f4f2015-09-15 14:41:29 -050056LOCALETREESRC ?= "${PKGD}"
57
58do_prep_locale_tree() {
59 treedir=${WORKDIR}/locale-tree
60 rm -rf $treedir
61 mkdir -p $treedir/${base_bindir} $treedir/${base_libdir} $treedir/${datadir} $treedir/${localedir}
62 tar -cf - -C ${LOCALETREESRC}${datadir} -p i18n | tar -xf - -C $treedir/${datadir}
63 # unzip to avoid parsing errors
64 for i in $treedir/${datadir}/i18n/charmaps/*gz; do
65 gunzip $i
66 done
Brad Bishop19323692019-04-05 15:28:33 -040067 # The extract pattern "./l*.so*" is carefully selected so that it will
68 # match ld*.so and lib*.so*, but not any files in the gconv directory
69 # (if it exists). This makes sure we only unpack the files we need.
70 # This is important in case usrmerge is set in DISTRO_FEATURES, which
71 # means ${base_libdir} == ${libdir}.
72 tar -cf - -C ${LOCALETREESRC}${base_libdir} -p . | tar -xf - -C $treedir/${base_libdir} --wildcards './l*.so*'
73 if [ -f ${STAGING_LIBDIR_NATIVE}/libgcc_s.* ]; then
74 tar -cf - -C ${STAGING_LIBDIR_NATIVE} -p libgcc_s.* | tar -xf - -C $treedir/${base_libdir}
Patrick Williamsc124f4f2015-09-15 14:41:29 -050075 fi
76 install -m 0755 ${LOCALETREESRC}${bindir}/localedef $treedir/${base_bindir}
77}
78
79do_collect_bins_from_locale_tree() {
80 treedir=${WORKDIR}/locale-tree
81
82 parent=$(dirname ${localedir})
83 mkdir -p ${PKGD}/$parent
84 tar -cf - -C $treedir/$parent -p $(basename ${localedir}) | tar -xf - -C ${PKGD}$parent
85}
86
87inherit qemu
88
89python package_do_split_gconvs () {
90 import re
Brad Bishop6e60e8b2018-02-01 10:27:11 -050091 if (d.getVar('PACKAGE_NO_GCONV') == '1'):
Patrick Williamsc124f4f2015-09-15 14:41:29 -050092 bb.note("package requested not splitting gconvs")
93 return
94
Brad Bishop6e60e8b2018-02-01 10:27:11 -050095 if not d.getVar('PACKAGES'):
Patrick Williamsc124f4f2015-09-15 14:41:29 -050096 return
97
Brad Bishop6e60e8b2018-02-01 10:27:11 -050098 mlprefix = d.getVar("MLPREFIX") or ""
Patrick Williamsc124f4f2015-09-15 14:41:29 -050099
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500100 bpn = d.getVar('BPN')
101 libdir = d.getVar('libdir')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500102 if not libdir:
103 bb.error("libdir not defined")
104 return
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500105 datadir = d.getVar('datadir')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500106 if not datadir:
107 bb.error("datadir not defined")
108 return
109
Brad Bishop316dfdd2018-06-25 12:45:53 -0400110 gconv_libdir = oe.path.join(libdir, "gconv")
111 charmap_dir = oe.path.join(datadir, "i18n", "charmaps")
112 locales_dir = oe.path.join(datadir, "i18n", "locales")
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500113 binary_locales_dir = d.getVar('localedir')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500114
115 def calc_gconv_deps(fn, pkg, file_regex, output_pattern, group):
116 deps = []
117 f = open(fn, "rb")
Brad Bishop19323692019-04-05 15:28:33 -0400118 c_re = re.compile(r'^copy "(.*)"')
119 i_re = re.compile(r'^include "(\w+)".*')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500120 for l in f.readlines():
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600121 l = l.decode("latin-1")
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500122 m = c_re.match(l) or i_re.match(l)
123 if m:
124 dp = legitimize_package_name('%s%s-gconv-%s' % (mlprefix, bpn, m.group(1)))
125 if not dp in deps:
126 deps.append(dp)
127 f.close()
128 if deps != []:
129 d.setVar('RDEPENDS_%s' % pkg, " ".join(deps))
130 if bpn != 'glibc':
131 d.setVar('RPROVIDES_%s' % pkg, pkg.replace(bpn, 'glibc'))
132
Brad Bishop19323692019-04-05 15:28:33 -0400133 do_split_packages(d, gconv_libdir, file_regex=r'^(.*)\.so$', output_pattern=bpn+'-gconv-%s', \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500134 description='gconv module for character set %s', hook=calc_gconv_deps, \
135 extra_depends=bpn+'-gconv')
136
137 def calc_charmap_deps(fn, pkg, file_regex, output_pattern, group):
138 deps = []
139 f = open(fn, "rb")
Brad Bishop19323692019-04-05 15:28:33 -0400140 c_re = re.compile(r'^copy "(.*)"')
141 i_re = re.compile(r'^include "(\w+)".*')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500142 for l in f.readlines():
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600143 l = l.decode("latin-1")
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500144 m = c_re.match(l) or i_re.match(l)
145 if m:
146 dp = legitimize_package_name('%s%s-charmap-%s' % (mlprefix, bpn, m.group(1)))
147 if not dp in deps:
148 deps.append(dp)
149 f.close()
150 if deps != []:
151 d.setVar('RDEPENDS_%s' % pkg, " ".join(deps))
152 if bpn != 'glibc':
153 d.setVar('RPROVIDES_%s' % pkg, pkg.replace(bpn, 'glibc'))
154
Brad Bishop19323692019-04-05 15:28:33 -0400155 do_split_packages(d, charmap_dir, file_regex=r'^(.*)\.gz$', output_pattern=bpn+'-charmap-%s', \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500156 description='character map for %s encoding', hook=calc_charmap_deps, extra_depends='')
157
158 def calc_locale_deps(fn, pkg, file_regex, output_pattern, group):
159 deps = []
160 f = open(fn, "rb")
Brad Bishop19323692019-04-05 15:28:33 -0400161 c_re = re.compile(r'^copy "(.*)"')
162 i_re = re.compile(r'^include "(\w+)".*')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500163 for l in f.readlines():
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600164 l = l.decode("latin-1")
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500165 m = c_re.match(l) or i_re.match(l)
166 if m:
167 dp = legitimize_package_name(mlprefix+bpn+'-localedata-%s' % m.group(1))
168 if not dp in deps:
169 deps.append(dp)
170 f.close()
171 if deps != []:
172 d.setVar('RDEPENDS_%s' % pkg, " ".join(deps))
173 if bpn != 'glibc':
174 d.setVar('RPROVIDES_%s' % pkg, pkg.replace(bpn, 'glibc'))
175
Brad Bishop19323692019-04-05 15:28:33 -0400176 do_split_packages(d, locales_dir, file_regex=r'(.*)', output_pattern=bpn+'-localedata-%s', \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500177 description='locale definition for %s', hook=calc_locale_deps, extra_depends='')
178 d.setVar('PACKAGES', d.getVar('PACKAGES', False) + ' ' + d.getVar('MLPREFIX', False) + bpn + '-gconv')
179
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500180 use_bin = d.getVar("GLIBC_INTERNAL_USE_BINARY_LOCALE")
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500181
Brad Bishop19323692019-04-05 15:28:33 -0400182 dot_re = re.compile(r"(.*)\.(.*)")
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500183
184 # Read in supported locales and associated encodings
185 supported = {}
Brad Bishop316dfdd2018-06-25 12:45:53 -0400186 with open(oe.path.join(d.getVar('WORKDIR'), "SUPPORTED")) as f:
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500187 for line in f.readlines():
188 try:
189 locale, charset = line.rstrip().split()
190 except ValueError:
191 continue
192 supported[locale] = charset
193
194 # GLIBC_GENERATE_LOCALES var specifies which locales to be generated. empty or "all" means all locales
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500195 to_generate = d.getVar('GLIBC_GENERATE_LOCALES')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500196 if not to_generate or to_generate == 'all':
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600197 to_generate = sorted(supported.keys())
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500198 else:
199 to_generate = to_generate.split()
200 for locale in to_generate:
201 if locale not in supported:
202 if '.' in locale:
203 charset = locale.split('.')[1]
204 else:
205 charset = 'UTF-8'
206 bb.warn("Unsupported locale '%s', assuming encoding '%s'" % (locale, charset))
207 supported[locale] = charset
208
209 def output_locale_source(name, pkgname, locale, encoding):
Patrick Williamsf1e5d692016-03-30 15:21:19 -0500210 d.setVar('RDEPENDS_%s' % pkgname, '%slocaledef %s-localedata-%s %s-charmap-%s' % \
211 (mlprefix, mlprefix+bpn, legitimize_package_name(locale), mlprefix+bpn, legitimize_package_name(encoding)))
Brad Bishopa5c52ff2018-11-23 10:55:50 +1300212 d.setVar('pkg_postinst_ontarget_%s' % pkgname, d.getVar('locale_base_postinst_ontarget') \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500213 % (locale, encoding, locale))
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500214 d.setVar('pkg_postrm_%s' % pkgname, d.getVar('locale_base_postrm') % \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500215 (locale, encoding, locale))
216
217 def output_locale_binary_rdepends(name, pkgname, locale, encoding):
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500218 dep = legitimize_package_name('%s-binary-localedata-%s' % (bpn, name))
219 lcsplit = d.getVar('GLIBC_SPLIT_LC_PACKAGES')
220 if lcsplit and int(lcsplit):
221 d.appendVar('PACKAGES', ' ' + dep)
222 d.setVar('ALLOW_EMPTY_%s' % dep, '1')
223 d.setVar('RDEPENDS_%s' % pkgname, mlprefix + dep)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500224
225 commands = {}
226
227 def output_locale_binary(name, pkgname, locale, encoding):
Brad Bishop316dfdd2018-06-25 12:45:53 -0400228 treedir = oe.path.join(d.getVar("WORKDIR"), "locale-tree")
229 ldlibdir = oe.path.join(treedir, d.getVar("base_libdir"))
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500230 path = d.getVar("PATH")
Brad Bishop316dfdd2018-06-25 12:45:53 -0400231 i18npath = oe.path.join(treedir, datadir, "i18n")
232 gconvpath = oe.path.join(treedir, "iconvdata")
233 outputpath = oe.path.join(treedir, binary_locales_dir)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500234
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500235 use_cross_localedef = d.getVar("LOCALE_GENERATION_WITH_CROSS-LOCALEDEF") or "0"
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500236 if use_cross_localedef == "1":
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500237 target_arch = d.getVar('TARGET_ARCH')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500238 locale_arch_options = { \
Brad Bishop19323692019-04-05 15:28:33 -0400239 "arc": " --uint32-align=4 --little-endian ", \
240 "arceb": " --uint32-align=4 --big-endian ", \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500241 "arm": " --uint32-align=4 --little-endian ", \
242 "armeb": " --uint32-align=4 --big-endian ", \
243 "aarch64": " --uint32-align=4 --little-endian ", \
244 "aarch64_be": " --uint32-align=4 --big-endian ", \
245 "sh4": " --uint32-align=4 --big-endian ", \
246 "powerpc": " --uint32-align=4 --big-endian ", \
247 "powerpc64": " --uint32-align=4 --big-endian ", \
248 "mips": " --uint32-align=4 --big-endian ", \
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600249 "mipsisa32r6": " --uint32-align=4 --big-endian ", \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500250 "mips64": " --uint32-align=4 --big-endian ", \
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600251 "mipsisa64r6": " --uint32-align=4 --big-endian ", \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500252 "mipsel": " --uint32-align=4 --little-endian ", \
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600253 "mipsisa32r6el": " --uint32-align=4 --little-endian ", \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500254 "mips64el":" --uint32-align=4 --little-endian ", \
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600255 "mipsisa64r6el":" --uint32-align=4 --little-endian ", \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800256 "riscv64": " --uint32-align=4 --little-endian ", \
257 "riscv32": " --uint32-align=4 --little-endian ", \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500258 "i586": " --uint32-align=4 --little-endian ", \
259 "i686": " --uint32-align=4 --little-endian ", \
260 "x86_64": " --uint32-align=4 --little-endian " }
261
262 if target_arch in locale_arch_options:
263 localedef_opts = locale_arch_options[target_arch]
264 else:
265 bb.error("locale_arch_options not found for target_arch=" + target_arch)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600266 bb.fatal("unknown arch:" + target_arch + " for locale_arch_options")
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500267
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600268 localedef_opts += " --force --no-archive --prefix=%s \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500269 --inputfile=%s/%s/i18n/locales/%s --charmap=%s %s/%s" \
270 % (treedir, treedir, datadir, locale, encoding, outputpath, name)
271
272 cmd = "PATH=\"%s\" I18NPATH=\"%s\" GCONV_PATH=\"%s\" cross-localedef %s" % \
273 (path, i18npath, gconvpath, localedef_opts)
274 else: # earlier slower qemu way
275 qemu = qemu_target_binary(d)
Patrick Williamsc0f7c042017-02-23 20:41:17 -0600276 localedef_opts = "--force --no-archive --prefix=%s \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500277 --inputfile=%s/i18n/locales/%s --charmap=%s %s" \
278 % (treedir, datadir, locale, encoding, name)
279
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500280 qemu_options = d.getVar('QEMU_OPTIONS')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500281
282 cmd = "PSEUDO_RELOADED=YES PATH=\"%s\" I18NPATH=\"%s\" %s -L %s \
Brad Bishop19323692019-04-05 15:28:33 -0400283 -E LD_LIBRARY_PATH=%s %s %s${base_bindir}/localedef %s" % \
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500284 (path, i18npath, qemu, treedir, ldlibdir, qemu_options, treedir, localedef_opts)
285
286 commands["%s/%s" % (outputpath, name)] = cmd
287
288 bb.note("generating locale %s (%s)" % (locale, encoding))
289
290 def output_locale(name, locale, encoding):
291 pkgname = d.getVar('MLPREFIX', False) + 'locale-base-' + legitimize_package_name(name)
292 d.setVar('ALLOW_EMPTY_%s' % pkgname, '1')
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500293 d.setVar('PACKAGES', '%s %s' % (pkgname, d.getVar('PACKAGES')))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500294 rprovides = ' %svirtual-locale-%s' % (mlprefix, legitimize_package_name(name))
Brad Bishop19323692019-04-05 15:28:33 -0400295 m = re.match(r"(.*)_(.*)", name)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500296 if m:
297 rprovides += ' %svirtual-locale-%s' % (mlprefix, m.group(1))
298 d.setVar('RPROVIDES_%s' % pkgname, rprovides)
299
300 if use_bin == "compile":
301 output_locale_binary_rdepends(name, pkgname, locale, encoding)
302 output_locale_binary(name, pkgname, locale, encoding)
303 elif use_bin == "precompiled":
304 output_locale_binary_rdepends(name, pkgname, locale, encoding)
305 else:
306 output_locale_source(name, pkgname, locale, encoding)
307
308 if use_bin == "compile":
309 bb.note("preparing tree for binary locale generation")
310 bb.build.exec_func("do_prep_locale_tree", d)
311
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500312 utf8_only = int(d.getVar('LOCALE_UTF8_ONLY') or 0)
313 utf8_is_default = int(d.getVar('LOCALE_UTF8_IS_DEFAULT') or 0)
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500314
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500315 encodings = {}
316 for locale in to_generate:
317 charset = supported[locale]
318 if utf8_only and charset != 'UTF-8':
319 continue
320
321 m = dot_re.match(locale)
322 if m:
323 base = m.group(1)
324 else:
325 base = locale
326
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500327 # Non-precompiled locales may be renamed so that the default
328 # (non-suffixed) encoding is always UTF-8, i.e., instead of en_US and
329 # en_US.UTF-8, we have en_US and en_US.ISO-8859-1. This implicitly
330 # contradicts SUPPORTED.
331 if use_bin == "precompiled" or not utf8_is_default:
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500332 output_locale(locale, base, charset)
333 else:
334 if charset == 'UTF-8':
335 output_locale(base, base, charset)
336 else:
337 output_locale('%s.%s' % (base, charset), base, charset)
338
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500339 def metapkg_hook(file, pkg, pattern, format, basename):
340 name = basename.split('/', 1)[0]
341 metapkg = legitimize_package_name('%s-binary-localedata-%s' % (mlprefix+bpn, name))
342 d.appendVar('RDEPENDS_%s' % metapkg, ' ' + pkg)
343
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500344 if use_bin == "compile":
Brad Bishop316dfdd2018-06-25 12:45:53 -0400345 makefile = oe.path.join(d.getVar("WORKDIR"), "locale-tree", "Makefile")
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500346 m = open(makefile, "w")
347 m.write("all: %s\n\n" % " ".join(commands.keys()))
Brad Bishop19323692019-04-05 15:28:33 -0400348 total = len(commands)
349 for i, cmd in enumerate(commands):
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500350 m.write(cmd + ":\n")
Brad Bishop19323692019-04-05 15:28:33 -0400351 m.write("\t@echo 'Progress %d/%d'\n" % (i, total))
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500352 m.write("\t" + commands[cmd] + "\n\n")
353 m.close()
354 d.setVar("EXTRA_OEMAKE", "-C %s ${PARALLEL_MAKE}" % (os.path.dirname(makefile)))
Brad Bishop19323692019-04-05 15:28:33 -0400355 d.setVarFlag("oe_runmake", "progress", "outof:Progress\s(\d+)/(\d+)")
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500356 bb.note("Executing binary locale generation makefile")
357 bb.build.exec_func("oe_runmake", d)
358 bb.note("collecting binary locales from locale tree")
359 bb.build.exec_func("do_collect_bins_from_locale_tree", d)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500360
361 if use_bin in ('compile', 'precompiled'):
362 lcsplit = d.getVar('GLIBC_SPLIT_LC_PACKAGES')
363 if lcsplit and int(lcsplit):
Brad Bishop19323692019-04-05 15:28:33 -0400364 do_split_packages(d, binary_locales_dir, file_regex=r'^(.*/LC_\w+)', \
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500365 output_pattern=bpn+'-binary-localedata-%s', \
366 description='binary locale definition for %s', recursive=True,
367 hook=metapkg_hook, extra_depends='', allow_dirs=True, match_path=True)
368 else:
Brad Bishop19323692019-04-05 15:28:33 -0400369 do_split_packages(d, binary_locales_dir, file_regex=r'(.*)', \
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500370 output_pattern=bpn+'-binary-localedata-%s', \
371 description='binary locale definition for %s', extra_depends='', allow_dirs=True)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500372 else:
373 bb.note("generation of binary locales disabled. this may break i18n!")
374
375}
376
377# We want to do this indirection so that we can safely 'return'
378# from the called function even though we're prepending
379python populate_packages_prepend () {
380 bb.build.exec_func('package_do_split_gconvs', d)
381}