blob: 8127e4a10b96b9b35a1c5a0fa4edd76c86e711fd [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001SUMMARY = "Userspace NFS server v3 protocol"
2SECTION = "console/network"
3LICENSE = "unfs3"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=9475885294e17c0cc0067820d042792e"
5
6# SVN support for upstream version check isn't implemented yet
7RECIPE_UPSTREAM_VERSION = "0.9.22.r497"
8RECIPE_UPSTREAM_DATE = "Oct 08, 2015"
9CHECK_DATE = "Dec 10, 2015"
10
11DEPENDS = "flex-native bison-native flex"
Brad Bishop00111322018-04-01 22:23:53 -040012DEPENDS += "libtirpc"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060013DEPENDS_append_class-nativesdk = " flex-nativesdk"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050014
Brad Bishop00111322018-04-01 22:23:53 -040015ASNEEDED = ""
16
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050017MOD_PV = "497"
18S = "${WORKDIR}/trunk"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050019# Only subversion url left in OE-Core, use a mirror tarball instead since
20# this rarely changes.
21# svn://svn.code.sf.net/p/unfs3/code;module=trunk;rev=${MOD_PV};protocol=http
Brad Bishopd7bf8c12018-02-25 22:55:05 -050022# rename the tarball in mirror to avoid clash with user local svn tarball
23SRC_URI = "http://downloads.yoctoproject.org/mirror/sources/unfs3-0.9.22.r497.tar.gz \
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050024 file://unfs3_parallel_build.patch \
25 file://alternate_rpc_ports.patch \
26 file://fix_pid_race_parent_writes_child_pid.patch \
27 file://fix_compile_warning.patch \
28 file://rename_fh_cache.patch \
29 file://relative_max_socket_path_len.patch \
30 file://tcp_no_delay.patch \
Brad Bishop00111322018-04-01 22:23:53 -040031 file://0001-daemon.c-Libtirpc-porting-fixes.patch \
32 "
Brad Bishop6e60e8b2018-02-01 10:27:11 -050033SRC_URI[md5sum] = "2e43e471c77ade0331901c40b8f8e9a3"
34SRC_URI[sha256sum] = "21009468a9ba07b72ea93780d025a63ab4e55bf8fc3127803c296f0900fe1bac"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050035
36BBCLASSEXTEND = "native nativesdk"
37
38inherit autotools
39EXTRA_OECONF_append_class-native = " --sbindir=${bindir}"
Brad Bishop00111322018-04-01 22:23:53 -040040CFLAGS_append = " -I${STAGING_INCDIR}/tirpc"
41LDFLAGS_append = " -ltirpc"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050042
43# Turn off these header detects else the inode search
44# will walk entire file systems and this is a real problem
45# if you have 2 TB of files to walk in your file system
46CACHED_CONFIGUREVARS = "ac_cv_header_mntent_h=no ac_cv_header_sys_mnttab_h=no"