blob: 2e0fecf7a9e290d209dec107562e96007b85a1e4 [file] [log] [blame]
Andre McCurdy1ea3f662016-12-15 06:11:31 -08001DESCRIPTION = "Google's framework for writing C++ tests"
Brad Bishop26bdd442019-08-16 17:08:17 -04002HOMEPAGE = "https://github.com/google/googletest"
Andre McCurdy1ea3f662016-12-15 06:11:31 -08003SECTION = "libs"
4LICENSE = "BSD-3-Clause"
William A. Kennington IIIb95905d2021-06-02 12:40:56 -07005LIC_FILES_CHKSUM = "file://LICENSE;md5=cbbd27594afd089daa160d3a16dd515a"
Andre McCurdy1ea3f662016-12-15 06:11:31 -08006
William A. Kennington IIIb95905d2021-06-02 12:40:56 -07007PV = "1.10.0+git${SRCPV}"
Brad Bishop996bc452019-12-02 13:05:15 -05008
Brad Bishop26bdd442019-08-16 17:08:17 -04009PROVIDES += "gmock gtest"
Andre McCurdy1ea3f662016-12-15 06:11:31 -080010
Brad Bishop316dfdd2018-06-25 12:45:53 -040011S = "${WORKDIR}/git"
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070012SRCREV = "662fe38e44900c007eccb65a5d2ea19df7bd520e"
Brad Bishop26bdd442019-08-16 17:08:17 -040013SRC_URI = "git://github.com/google/googletest.git"
Andre McCurdy1ea3f662016-12-15 06:11:31 -080014
Andre McCurdy1ea3f662016-12-15 06:11:31 -080015inherit cmake
16
17ALLOW_EMPTY_${PN} = "1"
18ALLOW_EMPTY_${PN}-dbg = "1"
19
20RDEPENDS_${PN}-dev += "${PN}-staticdev"
21
22BBCLASSEXTEND = "native nativesdk"
Brad Bishope42b3e32020-01-15 22:08:42 -050023
24do_configure_prepend() {
25 # explicitly use python3
26 # the scripts are already python3 compatible since https://github.com/google/googletest/commit/d404af0d987a9c38cafce82a7e26ec8468c88361 and other fixes like this
27 # but since this oe-core change http://git.openembedded.org/openembedded-core/commit/?id=5f8f16b17f66966ae91aeabc23e97de5ecd17447
28 # there isn't python in HOSTTOOLS so "env python" fails
29 sed -i 's@^#!/usr/bin/env python$@#!/usr/bin/env python3@g' ${S}/googlemock/scripts/*py ${S}/googlemock/scripts/generator/*py ${S}/googlemock/scripts/generator/cpp/*py ${S}/googlemock/test/*py ${S}/googletest/scripts/*py ${S}/googletest/test/*py
30}