blob: 354e7de3379ad3563333da800c03b422959401cb [file] [log] [blame]
Andre McCurdy1ea3f662016-12-15 06:11:31 -08001DESCRIPTION = "Google's framework for writing C++ tests"
Brad Bishop26bdd442019-08-16 17:08:17 -04002HOMEPAGE = "https://github.com/google/googletest"
Andre McCurdy1ea3f662016-12-15 06:11:31 -08003SECTION = "libs"
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://googlemock/LICENSE;md5=cbbd27594afd089daa160d3a16dd515a \
6 file://googletest/LICENSE;md5=cbbd27594afd089daa160d3a16dd515a"
7
Brad Bishop996bc452019-12-02 13:05:15 -05008PV = "1.10.0"
9
Brad Bishop26bdd442019-08-16 17:08:17 -040010PROVIDES += "gmock gtest"
Andre McCurdy1ea3f662016-12-15 06:11:31 -080011
Brad Bishop316dfdd2018-06-25 12:45:53 -040012S = "${WORKDIR}/git"
Brad Bishop8410d612019-11-25 09:40:59 -050013SRCREV = "703bd9caab50b139428cea1aaff9974ebee5742e"
Brad Bishop26bdd442019-08-16 17:08:17 -040014SRC_URI = "git://github.com/google/googletest.git"
Andre McCurdy1ea3f662016-12-15 06:11:31 -080015
Andre McCurdy1ea3f662016-12-15 06:11:31 -080016inherit cmake
17
18ALLOW_EMPTY_${PN} = "1"
19ALLOW_EMPTY_${PN}-dbg = "1"
20
21RDEPENDS_${PN}-dev += "${PN}-staticdev"
22
23BBCLASSEXTEND = "native nativesdk"
Brad Bishope42b3e32020-01-15 22:08:42 -050024
25do_configure_prepend() {
26 # explicitly use python3
27 # the scripts are already python3 compatible since https://github.com/google/googletest/commit/d404af0d987a9c38cafce82a7e26ec8468c88361 and other fixes like this
28 # but since this oe-core change http://git.openembedded.org/openembedded-core/commit/?id=5f8f16b17f66966ae91aeabc23e97de5ecd17447
29 # there isn't python in HOSTTOOLS so "env python" fails
30 sed -i 's@^#!/usr/bin/env python$@#!/usr/bin/env python3@g' ${S}/googlemock/scripts/*py ${S}/googlemock/scripts/generator/*py ${S}/googlemock/scripts/generator/cpp/*py ${S}/googlemock/test/*py ${S}/googletest/scripts/*py ${S}/googletest/test/*py
31}