blob: 08b8552622b2ebe7e4084638abfb8e25e1ff9dc4 [file] [log] [blame]
Brad Bishop2f973922019-11-11 07:58:48 -05001SUMMARY = "HTTP/2 C Library and tools"
2HOMEPAGE = "https://nghttp2.org/"
3SECTION = "libs"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=764abdf30b2eadd37ce47dcbce0ea1ec"
6DEPENDS = "c-ares cunit jansson libev libevent libxml2 openssl zlib"
7
8UPSTREAM_CHECK_URI = "https://github.com/nghttp2/nghttp2/releases"
9
10SRC_URI = "\
11 https://github.com/nghttp2/nghttp2/releases/download/v${PV}/nghttp2-${PV}.tar.xz \
12 file://0001-fetch-ocsp-response-use-python3.patch \
13"
Andrew Geisslerac970dd2021-02-12 15:32:45 -060014SRC_URI[sha256sum] = "f7d54fa6f8aed29f695ca44612136fa2359013547394d5dffeffca9e01a26b0f"
Brad Bishop2f973922019-11-11 07:58:48 -050015
Andrew Geissler82c905d2020-04-13 13:39:40 -050016inherit cmake manpages python3native
Brad Bishop2f973922019-11-11 07:58:48 -050017PACKAGECONFIG[manpages] = ""
18
19# examples are never installed, and don't need to be built in the
20# first place
Andrew Geissler69721092021-07-23 12:57:00 -040021EXTRA_OECMAKE = "-DENABLE_EXAMPLES=OFF -DENABLE_APP=ON -DENABLE_HPACK_TOOLS=OFF"
Brad Bishop2f973922019-11-11 07:58:48 -050022
23PACKAGES =+ "lib${PN} ${PN}-client ${PN}-proxy ${PN}-server"
24
25RDEPENDS_${PN} = "${PN}-client (>= ${PV}) ${PN}-proxy (>= ${PV}) ${PN}-server (>= ${PV})"
26RDEPENDS_${PN}_class-native = ""
27RDEPENDS_${PN}-proxy = "openssl python3-core python3-io python3-shell"
28
29ALLOW_EMPTY_${PN} = "1"
30FILES_${PN} = ""
31FILES_lib${PN} = "${libdir}/*${SOLIBS}"
32FILES_${PN}-client = "${bindir}/h2load ${bindir}/nghttp"
33FILES_${PN}-proxy = "${bindir}/nghttpx ${datadir}/${BPN}/fetch-ocsp-response"
34FILES_${PN}-server = "${bindir}/nghttpd"
35
36BBCLASSEXTEND = "native"