Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "Support for reading various archive formats" |
| 2 | DESCRIPTION = "C library and command-line tools for reading and writing tar, cpio, zip, ISO, and other archive formats" |
| 3 | HOMEPAGE = "http://www.libarchive.org/" |
| 4 | SECTION = "devel" |
| 5 | LICENSE = "BSD-2-Clause" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=d499814247adaee08d88080841cb5665" |
| 7 | |
| 8 | DEPENDS = "e2fsprogs-native" |
| 9 | |
| 10 | PACKAGECONFIG ?= "zlib bz2 xz lzo zstd" |
| 11 | |
| 12 | PACKAGECONFIG:append:class-target = "\ |
| 13 | ${@bb.utils.filter('DISTRO_FEATURES', 'acl xattr', d)} \ |
| 14 | " |
| 15 | |
| 16 | DEPENDS_BZIP2 = "bzip2-replacement-native" |
| 17 | DEPENDS_BZIP2:class-target = "bzip2" |
| 18 | |
| 19 | PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl," |
| 20 | PACKAGECONFIG[xattr] = "--enable-xattr,--disable-xattr,attr," |
| 21 | PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib," |
| 22 | PACKAGECONFIG[bz2] = "--with-bz2lib,--without-bz2lib,${DEPENDS_BZIP2}," |
| 23 | PACKAGECONFIG[xz] = "--with-lzma,--without-lzma,xz," |
| 24 | PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl," |
| 25 | PACKAGECONFIG[libxml2] = "--with-xml2,--without-xml2,libxml2," |
| 26 | PACKAGECONFIG[expat] = "--with-expat,--without-expat,expat," |
| 27 | PACKAGECONFIG[lzo] = "--with-lzo2,--without-lzo2,lzo," |
| 28 | PACKAGECONFIG[nettle] = "--with-nettle,--without-nettle,nettle," |
| 29 | PACKAGECONFIG[lz4] = "--with-lz4,--without-lz4,lz4," |
| 30 | PACKAGECONFIG[mbedtls] = "--with-mbedtls,--without-mbedtls,mbedtls," |
| 31 | PACKAGECONFIG[zstd] = "--with-zstd,--without-zstd,zstd," |
| 32 | |
| 33 | EXTRA_OECONF += "--enable-largefile" |
| 34 | |
| 35 | SRC_URI = "http://libarchive.org/downloads/libarchive-${PV}.tar.gz" |
| 36 | UPSTREAM_CHECK_URI = "http://libarchive.org/" |
| 37 | |
Patrick Williams | 5877637 | 2022-04-13 09:07:35 -0500 | [diff] [blame] | 38 | SRC_URI[sha256sum] = "c676146577d989189940f1959d9e3980d28513d74eedfbc6b7f15ea45fe54ee2" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 39 | |
| 40 | inherit autotools update-alternatives pkgconfig |
| 41 | |
| 42 | CPPFLAGS += "-I${WORKDIR}/extra-includes" |
| 43 | |
| 44 | do_configure[cleandirs] += "${WORKDIR}/extra-includes" |
| 45 | do_configure:prepend() { |
| 46 | # We just need the headers for some type constants, so no need to |
| 47 | # build all of e2fsprogs for the target |
| 48 | cp -R ${STAGING_INCDIR_NATIVE}/ext2fs ${WORKDIR}/extra-includes/ |
| 49 | } |
| 50 | |
| 51 | ALTERNATIVE_PRIORITY = "80" |
| 52 | |
| 53 | PACKAGES =+ "bsdtar" |
| 54 | FILES:bsdtar = "${bindir}/bsdtar" |
| 55 | |
| 56 | ALTERNATIVE:bsdtar = "tar" |
| 57 | ALTERNATIVE_LINK_NAME[tar] = "${base_bindir}/tar" |
| 58 | ALTERNATIVE_TARGET[tar] = "${bindir}/bsdtar" |
| 59 | |
| 60 | PACKAGES =+ "bsdcpio" |
| 61 | FILES:bsdcpio = "${bindir}/bsdcpio" |
| 62 | |
| 63 | ALTERNATIVE:bsdcpio = "cpio" |
| 64 | ALTERNATIVE_LINK_NAME[cpio] = "${base_bindir}/cpio" |
| 65 | ALTERNATIVE_TARGET[cpio] = "${bindir}/bsdcpio" |
| 66 | |
| 67 | BBCLASSEXTEND = "native nativesdk" |