Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Ninja is a small build system with a focus on speed." |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 2 | HOMEPAGE = "https://ninja-build.org/" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 3 | DESCRIPTION = "Ninja is a small build system with a focus on speed. It differs from other build systems in two major respects: it is designed to have its input files generated by a higher-level build system, and it is designed to run builds as fast as possible." |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=a81586a64ad4e476c791cda7e2f2c52e" |
| 6 | |
| 7 | DEPENDS = "re2c-native ninja-native" |
| 8 | |
Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 9 | SRCREV = "a524bf3f6bacd1b4ad85d719eed2737d8562f27a" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 10 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 11 | SRC_URI = "git://github.com/ninja-build/ninja.git;branch=release;protocol=https" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 12 | UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>.*)" |
| 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | do_configure[noexec] = "1" |
| 17 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 18 | do_compile:class-native() { |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 19 | python3 ./configure.py --bootstrap |
| 20 | } |
| 21 | |
| 22 | do_compile() { |
| 23 | python3 ./configure.py |
| 24 | ninja |
| 25 | } |
| 26 | |
| 27 | do_install() { |
| 28 | install -D -m 0755 ${S}/ninja ${D}${bindir}/ninja |
| 29 | } |
| 30 | |
| 31 | BBCLASSEXTEND = "native nativesdk" |
Patrick Williams | b542dec | 2023-06-09 01:26:37 -0500 | [diff] [blame] | 32 | |
| 33 | # This is a different Ninja |
| 34 | CVE_CHECK_IGNORE += "CVE-2021-4336" |