blob: 5dc87bd91ac6c117fb23a3cacabc844d0cab78db [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "The tdb library"
2HOMEPAGE = "https://tdb.samba.org/"
3SECTION = "libs"
4LICENSE = "LGPL-3.0-or-later & GPL-3.0-or-later"
5
6LIC_FILES_CHKSUM = "file://tools/tdbdump.c;endline=18;md5=b59cd45aa8624578126a8c98f48018c4 \
7 file://include/tdb.h;endline=27;md5=f5bb544641d3081821bcc1dd58310be6"
8
9export PYTHONHASHSEED="1"
10
11SRC_URI = "https://samba.org/ftp/tdb/tdb-${PV}.tar.gz \
12 file://0001-tdb-Add-configure-options-for-packages.patch \
13 file://0002-Fix-pyext_PATTERN-for-cross-compilation.patch \
14"
15
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060016SRC_URI[sha256sum] = "8434c9c857d13ce3fa8466f75601f25c3693676b36919f159e0ad6121baf5ce8"
Andrew Geissler517393d2023-01-13 08:55:19 -060017
18PACKAGECONFIG ??= "\
19 ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)} \
20 ${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'attr', '', d)} \
21"
22
23PACKAGECONFIG[acl] = "--with-acl,--without-acl,acl"
24PACKAGECONFIG[attr] = "--with-attr,--without-attr,attr"
25PACKAGECONFIG[libaio] = "--with-libaio,--without-libaio,libaio"
26PACKAGECONFIG[libbsd] = "--with-libbsd,--without-libbsd,libbsd"
27PACKAGECONFIG[libcap] = "--with-libcap,--without-libcap,libcap"
28PACKAGECONFIG[valgrind] = "--with-valgrind,--without-valgrind,valgrind"
29
30S = "${WORKDIR}/tdb-${PV}"
31
32inherit waf-samba
33
34#cross_compile cannot use preforked process, since fork process earlier than point subproces.popen
35#to cross Popen
36export WAF_NO_PREFORK="yes"
37
38EXTRA_OECONF += "--disable-rpath \
39 --disable-rpath-install \
40 --bundled-libraries=NONE \
41 --builtin-libraries=replace \
42 --with-libiconv=${STAGING_DIR_HOST}${prefix}\
43 "
44
45PACKAGES += "tdb-tools python3-tdb"
46
47RPROVIDES:${PN}-dbg += "python3-tdb-dbg"
48
49FILES:${PN} = "${libdir}/*.so.*"
50FILES:tdb-tools = "${bindir}/*"
51FILES:python3-tdb = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/*"
52RDEPENDS:python3-tdb = "python3"
53INSANE_SKIP:${MLPREFIX}python3-tdb = "dev-so"