blob: b34c186ca59c695b1b03157f39d1f438cedceb34 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Hierarchical, reference counted memory pool system with destructors"
2HOMEPAGE = "https://tevent.samba.org"
3SECTION = "libs"
4LICENSE = "LGPL-3.0-or-later"
5
6DEPENDS += "libtalloc libtirpc"
7RDEPENDS:python3-tevent = "python3"
8
9export PYTHONHASHSEED="1"
10
11SRC_URI = "https://samba.org/ftp/tevent/tevent-${PV}.tar.gz \
12 file://0001-Add-configure-options-for-packages.patch \
13 file://0002-Fix-pyext_PATTERN-for-cross-compilation.patch \
14 "
15
16SRC_URI:append:libc-musl = " file://cmocka-fix-musl-libc-conflicting-types-error.patch"
17
18LIC_FILES_CHKSUM = "file://tevent.h;endline=26;md5=47386b7c539bf2706b7ce52dc9341681"
19
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060020SRC_URI[sha256sum] = "ef85fcaa80ffd2351036ba4b347630fef2a1ac3da964a7f1820466bad03cd00d"
Andrew Geissler517393d2023-01-13 08:55:19 -060021
Andrew Geisslerc5535c92023-01-27 16:10:19 -060022inherit pkgconfig ptest waf-samba
Andrew Geissler517393d2023-01-13 08:55:19 -060023
24PACKAGECONFIG ??= "\
25 ${@bb.utils.filter('DISTRO_FEATURES', 'acl', d)} \
26 ${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'attr', '', d)} \
27"
28PACKAGECONFIG[acl] = "--with-acl,--without-acl,acl"
29PACKAGECONFIG[attr] = "--with-attr,--without-attr,attr"
30PACKAGECONFIG[libaio] = "--with-libaio,--without-libaio,libaio"
31PACKAGECONFIG[libbsd] = "--with-libbsd,--without-libbsd,libbsd"
32PACKAGECONFIG[libcap] = "--with-libcap,--without-libcap,libcap"
33PACKAGECONFIG[valgrind] = "--with-valgrind,--without-valgrind,valgrind"
34
35SRC_URI += "${@bb.utils.contains('PACKAGECONFIG', 'attr', '', 'file://avoid-attr-unless-wanted.patch', d)}"
36
37S = "${WORKDIR}/tevent-${PV}"
38
39#cross_compile cannot use preforked process, since fork process earlier than point subproces.popen
40#to cross Popen
41export WAF_NO_PREFORK="yes"
42
43EXTRA_OECONF += "--disable-rpath \
44 --disable-rpath-install \
45 --bundled-libraries=cmocka \
46 --builtin-libraries=replace \
47 --with-libiconv=${STAGING_DIR_HOST}${prefix}\
48 --without-gettext \
49 "
50
Andrew Geisslerc5535c92023-01-27 16:10:19 -060051do_install:append() {
52 install -Dm 0755 ${B}/bin/test_tevent_trace ${D}${bindir}/test_tevent_trace
53 install -Dm 0755 ${B}/bin/test_tevent_tag ${D}${bindir}/test_tevent_tag
54 install -Dm 0755 ${B}/bin/replace_testsuite ${D}${bindir}/replace_testsuite
55}
56
Andrew Geissler517393d2023-01-13 08:55:19 -060057PACKAGES += "python3-tevent"
58
59RPROVIDES:${PN}-dbg += "python3-tevent-dbg"
60
61FILES:${PN} += "${libdir}/tevent/*"
Andrew Geisslerc5535c92023-01-27 16:10:19 -060062FILES:${PN}-ptest += "${bindir}/replace_testsuite \
63 ${bindir}/test_tevent_tag \
64 ${bindir}/test_tevent_trace \
65 ${libdir}/libcmocka-tevent.so"
Andrew Geissler517393d2023-01-13 08:55:19 -060066FILES:python3-tevent = "${libdir}/python${PYTHON_BASEVERSION}/site-packages/*"
67
68INSANE_SKIP:${MLPREFIX}python3-tevent = "dev-so"