blob: fe44ef965efc7d94f9febb409c50227031183cb0 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "ModemManager is a daemon controlling broadband devices/connections"
2DESCRIPTION = "ModemManager is a DBus-activated daemon which controls mobile broadband (2G/3G/4G) devices and connections"
3HOMEPAGE = "http://www.freedesktop.org/wiki/Software/ModemManager/"
4LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later"
5LIC_FILES_CHKSUM = " \
6 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c \
8"
9
10GNOMEBASEBUILDCLASS = "meson"
11inherit gnomebase gettext systemd gobject-introspection bash-completion
12
13DEPENDS = "glib-2.0 libgudev libxslt-native dbus"
14
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060015SRCREV = "6926459500fd927e7cceb589a9e4113d4edb04e6"
16SRC_URI = "git://gitlab.freedesktop.org/mobile-broadband/ModemManager.git;protocol=https;branch=mm-1-20"
Andrew Geissler9aee5002022-03-30 16:27:02 +000017
18S = "${WORKDIR}/git"
19
20# strict, permissive
21MODEMMANAGER_POLKIT_TYPE ??= "permissive"
22
23PACKAGECONFIG ??= "vala mbim qmi \
24 ${@bb.utils.filter('DISTRO_FEATURES', 'systemd polkit', d)} \
25"
26
27PACKAGECONFIG[at] = "-Dat_command_via_dbus=true"
28PACKAGECONFIG[systemd] = " \
29 -Dsystemdsystemunitdir=${systemd_unitdir}/system/, \
30 -Dsystemdsystemunitdir=no -Dsystemd_journal=false -Dsystemd_suspend_resume=false \
31"
32PACKAGECONFIG[polkit] = "-Dpolkit=${MODEMMANAGER_POLKIT_TYPE},-Dpolkit=no,polkit"
33# Support WWAN modems and devices which speak the Mobile Interface Broadband Model (MBIM) protocol.
34PACKAGECONFIG[mbim] = "-Dmbim=true,-Dmbim=false -Dplugin_dell=disabled -Dplugin_foxconn=disabled,libmbim"
35# Support WWAN modems and devices which speak the Qualcomm MSM Interface (QMI) protocol.
36PACKAGECONFIG[qmi] = "-Dqmi=true,-Dqmi=false,libqmi"
37PACKAGECONFIG[qrtr] = "-Dqrtr=true,-Dqrtr=false,libqrtr-glib"
38PACKAGECONFIG[vala] = "-Dvapi=true,-Dvapi=false"
39
40inherit ${@bb.utils.contains('PACKAGECONFIG', 'vala', 'vala', '', d)}
41
42EXTRA_OEMESON = " \
43 -Dudevdir=${nonarch_base_libdir}/udev \
44 -Dqrtr=false \
45"
46
47FILES:${PN} += " \
48 ${datadir}/icons \
49 ${datadir}/polkit-1 \
50 ${datadir}/dbus-1 \
51 ${datadir}/ModemManager \
52 ${libdir}/ModemManager \
53 ${systemd_unitdir}/system \
54"
55
56SYSTEMD_SERVICE:${PN} = "ModemManager.service"