blob: 68d40425548f7e7a4fe1a6d3c73b314b0297a2f7 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001#
2# Copyright (C) 2014 - 2017 Wind River Systems, Inc.
3#
4SUMMARY = "Base policy for CFEngine"
5
6DESCRIPTION = "CFEngine is an IT infrastructure automation framework \
7that helps engineers, system administrators and other stakeholders \
8in an IT system to manage and understand IT infrastructure throughout \
9its lifecycle. CFEngine takes systems from Build to Deploy, Manage and Audit. \
10 \
11This package is intended to provide a stable base policy for \
12installations and upgrades, and is used by CFEngine 3.6 and newer. \
13 \
14The contents of this packge are intended to live in `/var/cfengine/masterfiles` \
15or wherever `$(sys.masterdir)` points. \
16"
17
18HOMEPAGE = "http://cfengine.com"
19
20LICENSE = "MIT"
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060021LIC_FILES_CHKSUM = "file://LICENSE;md5=bb843e794feb6890f7697637b461c36e"
Andrew Geissler82c905d2020-04-13 13:39:40 -050022
23SRC_URI = "https://cfengine-package-repos.s3.amazonaws.com/tarballs/${BP}.tar.gz \
Andrew Geissler82c905d2020-04-13 13:39:40 -050024 "
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060025#SRC_URI[md5sum] = "5df2f85c75efc351ffadebcc11046a98"
26SRC_URI[sha256sum] = "013ebe68599915cedb4bf753b471713d91901a991623358b9a967d9a779bcc16"
Andrew Geissler82c905d2020-04-13 13:39:40 -050027
28inherit autotools
29
30export EXPLICIT_VERSION="${PV}"
31
32EXTRA_OECONF = "--prefix=${datadir}/cfengine"
33
Patrick Williams213cb262021-08-07 19:21:33 -050034do_install:append() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050035 rm -rf ${D}${datadir}/cfengine/modules/packages/zypper ${D}${datadir}/cfengine/modules/packages/yum
36}
37
Patrick Williams213cb262021-08-07 19:21:33 -050038FILES:${PN} = "${datadir}/cfengine"
Andrew Geissler82c905d2020-04-13 13:39:40 -050039
Patrick Williams213cb262021-08-07 19:21:33 -050040RDEPENDS:${PN} += "python3-core"