blob: 89b7cfd184a5d9e0e14cc1a65983854d001a46f3 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001DESCRIPTION = "The glog library implements application-level logging. This \
2library provides logging APIs based on C++-style streams and various helper \
3macros."
4HOMEPAGE = "https://github.com/google/glog"
5
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://COPYING;md5=dc9db360e0bbd4e46672f3fd91dd6c4b"
8
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08009SRC_URI = " \
Andrew Geissler595f6302022-01-24 19:11:47 +000010 git://github.com/google/glog.git;nobranch=1;protocol=https \
Andrew Geissler32b11992021-03-31 13:37:05 -050011 file://libexecinfo.patch \
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060012 file://0001-Change-SleepForMilliseconds-parameter-from-unsigned-.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080013"
14
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060015SRCREV = "b33e3bad4c46c8a6345525fd822af355e5ef9446"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080016
17S = "${WORKDIR}/git"
18
19inherit cmake
20
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060021PACKAGECONFIG ?= "shared unwind 64bit-atomics"
Patrick Williams213cb262021-08-07 19:21:33 -050022PACKAGECONFIG:remove:riscv64 = "unwind"
23PACKAGECONFIG:remove:riscv32 = "unwind"
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060024PACKAGECONFIG:remove:mipsarch = "64bit-atomics"
25
Patrick Williams213cb262021-08-07 19:21:33 -050026PACKAGECONFIG:append:libc-musl:riscv64 = " execinfo"
27PACKAGECONFIG:append:libc-musl:riscv32 = " execinfo"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080028
Andrew Geissler82c905d2020-04-13 13:39:40 -050029PACKAGECONFIG[unwind] = "-DWITH_UNWIND=ON,-DWITH_UNWIND=OFF,libunwind,libunwind"
Andrew Geissler32b11992021-03-31 13:37:05 -050030PACKAGECONFIG[execinfo] = ",,libexecinfo"
Andrew Geissler82c905d2020-04-13 13:39:40 -050031PACKAGECONFIG[shared] = "-DBUILD_SHARED_LIBS=ON,-DBUILD_SHARED_LIBS=OFF,,"
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060032PACKAGECONFIG[64bit-atomics] = ",-DCMAKE_CXX_STANDARD_LIBRARIES='-latomic',,"
Andrew Geisslera2681d92020-10-16 10:17:07 -050033
Patrick Williams213cb262021-08-07 19:21:33 -050034do_configure:append() {
Andrew Geisslera2681d92020-10-16 10:17:07 -050035 # remove WORKDIR info to improve reproducibility
36 if [ -f "${B}/config.h" ] ; then
37 sed -i 's/'$(echo ${WORKDIR} | sed 's_/_\\/_g')'/../g' ${B}/config.h
38 fi
39}