blob: 878d28f1373d2b26d5d6ddddea71c0b9d535ea09 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "IMAPFilter is a mail filtering utility that processes mailboxes based on IMAP queries"
2LICENSE = "MIT"
Andrew Geisslerc5535c92023-01-27 16:10:19 -06003LIC_FILES_CHKSUM = "file://LICENSE;md5=f8d2fc4954306888fd0e4b27bef83525"
Andrew Geissler517393d2023-01-13 08:55:19 -06004
5# v2.7.6
Andrew Geisslerc5535c92023-01-27 16:10:19 -06006SRCREV = "e6372b88e09a4d1c573b57270de6b40846825a8b"
Andrew Geissler517393d2023-01-13 08:55:19 -06007SRC_URI = "git://github.com/lefcha/imapfilter;protocol=https;branch=master \
8 file://ldflags.patch \
9"
10S = "${WORKDIR}/git"
11
12DEPENDS= "openssl lua libpcre2"
13
14EXTRA_OEMAKE:append = " PREFIX=${prefix}"
15
16do_install(){
17 oe_runmake DESTDIR=${D} install
18
19 # No need for manuals at this point, MANDIR is hardcoded to depend on prefix
20 rm -rf ${D}${prefix}/man
21}
22
23ASNEEDED = ""