blob: 7d8c2f596d46ea80b91ef358f205730949a32cc1 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "This is the io_uring library, liburing."
2DESCRIPTION = "liburing provides helpers to setup and teardown io_uring \
3instances, and also a simplified interface for applications that don't need \
4(or want) to deal with the full kernel side implementation."
5HOMEPAGE = "https://github.com/axboe/liburing"
6BUGTRACKER = "https://github.com/axboe/liburing/issues"
7SECTION = "libs"
8
Andrew Geissler9aee5002022-03-30 16:27:02 +00009LICENSE = "LGPL-2.1-only | MIT"
Andrew Geissler615f2f12022-07-15 14:00:58 -050010LIC_FILES_CHKSUM = "file://README;beginline=41;endline=44;md5=2b0e9926530c269f5ae95560370195af"
Andrew Geissler595f6302022-01-24 19:11:47 +000011
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060012SRC_URI = "git://github.com/axboe/liburing.git;branch=master;protocol=https \
13 file://0001-examples-test-Remove-unused-linux-errqueue.h.patch"
Andrew Geissler595f6302022-01-24 19:11:47 +000014SRC_URI:append:libc-musl:riscv64 = " file://0001-do-not-build-examples.patch "
15SRC_URI:append:libc-musl:riscv32 = " file://0001-do-not-build-examples.patch "
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060016SRCREV = "f5cac78e621ab452d3035902085f66d2bf73243b"
Andrew Geissler595f6302022-01-24 19:11:47 +000017
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060018PV .= "+2.4+git${SRCPV}"
Andrew Geissler595f6302022-01-24 19:11:47 +000019S = "${WORKDIR}/git"
20
21DEPENDS:append:libc-musl = " libucontext"
22XCFLAGS = "-pthread"
23XCFLAGS:append:libc-musl = " -lucontext"
24
25EXTRA_OEMAKE = "'CC=${CC}' 'RANLIB=${RANLIB}' 'AR=${AR}' 'CFLAGS=${CFLAGS} -I${S}/include -DWITHOUT_XATTR' 'LDFLAGS=${LDFLAGS}' 'XCFLAGS=${XCFLAGS}' 'BUILDDIR=${S}'"
26do_configure() {
Andrew Geissler9aee5002022-03-30 16:27:02 +000027 ${S}/configure --prefix=${prefix} --libdir=${libdir} --libdevdir=${libdir} --mandir=${mandir} --datadir=${datadir} --includedir=${includedir}
Andrew Geissler595f6302022-01-24 19:11:47 +000028}
29do_install () {
Andrew Geissler9aee5002022-03-30 16:27:02 +000030 oe_runmake install DESTDIR=${D}
Andrew Geissler595f6302022-01-24 19:11:47 +000031}
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060032
33BBCLASSEXTEND = "native nativesdk"