blob: 4d592308ac5dcbd37b8c3b08c6bfece255048522 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001DESCRIPTION = "Provides modules to easily parse localized dates in almost any string formats commonly found on web pages"
2HOMEPAGE = "https://github.com/scrapinghub/dateparser"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=3d3ed25571191e7aa3f55d0a6efe0051"
5
Andrew Geissler6aa7eec2023-03-03 12:41:14 -06006SRC_URI[sha256sum] = "ff047d9cffad4d3113ead8ec0faf8a7fc43bab7d853ac8715e071312b53c465a"
Andrew Geissler517393d2023-01-13 08:55:19 -06007
8PYPI_PACKAGE = "dateparser"
9
10inherit pypi setuptools3
11
12CLEANBROKEN = "1"
13
14RDEPENDS:${PN} += " \
15 ${PYTHON_PN}-dateutil \
16 ${PYTHON_PN}-tzlocal \
17 ${PYTHON_PN}-ruamel-yaml \
18"
19
20# Ommitted ${PYTHON_PN}-convertdate, ${PYTHON_PN}-jdatetime ${PYTHON_PN}-umalqurra