blob: f9b4b64a50351095be6827935e1dfb452d9eab24 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001# Copyright (C) 2015 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4DESCRIPTION = "Python library for CSON (schema-compressed JSON)"
5HOMEPAGE = "https://github.com/gt3389b/python-cson/"
6LICENSE = "MIT"
7SECTION = "devel/python"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=7709d2635e63ab96973055a23c2a4cac"
9
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060010PV = "1.0.9+1.0.10"
11SRCREV = "69090778bccc5ed124342ba288597fbb2bfa9f39"
12SRC_URI = "git://github.com/gt3389b/python-cson.git;branch=master;protocol=https \
13 file://0001-setup.py-Do-not-poke-at-git-describe-to-find-version.patch"
Andrew Geissler82c905d2020-04-13 13:39:40 -050014
15S = "${WORKDIR}/git"
16
Patrick Williams213cb262021-08-07 19:21:33 -050017RDEPENDS:${PN}:class-native = ""
18DEPENDS:append:class-native = " python-native "
Andrew Geissler82c905d2020-04-13 13:39:40 -050019
20inherit setuptools3
21
Andrew Geissler9aee5002022-03-30 16:27:02 +000022PIP_INSTALL_PACKAGE = "python_cson"
23
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060024do_configure:prepend() {
25 echo "__version__=${PV}" > ${S}/version.py
26}
27
Andrew Geissler82c905d2020-04-13 13:39:40 -050028BBCLASSEXTEND = "native"
29