blob: cbf2a7a33748a32f9c5bfbfeb0a0ed88126d4787 [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "Python WBEM Client and Provider Interface"
2DESCRIPTION = "\
3A Python library for making CIM (Common Information Model) operations over \
4HTTP using the WBEM CIM-XML protocol. It is based on the idea that a good \
5WBEM client should be easy to use and not necessarily require a large amount \
6of programming knowledge. It is suitable for a large range of tasks from \
7simply poking around to writing web and GUI applications. \
8\
9WBEM, or Web Based Enterprise Management is a manageability protocol, like \
10SNMP, standardised by the Distributed Management Task Force (DMTF) available \
11at http://www.dmtf.org/standards/wbem. \
12\
13It also provides a Python provider interface, and is the fastest and easiest \
14way to write providers on the planet."
15HOMEPAGE = "http://pywbem.github.io"
Andrew Geissler9aee5002022-03-30 16:27:02 +000016LICENSE = "LGPL-2.1-only"
Andrew Geissler595f6302022-01-24 19:11:47 +000017LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=fbc093901857fcd118f065f900982c24"
18
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060019SRC_URI[sha256sum] = "e26ab0324475ee5329d74971f942b4b315b6ac0edaf278e70e16b5603278ef98"
Andrew Geissler595f6302022-01-24 19:11:47 +000020
21inherit pypi setuptools3 update-alternatives
22
23DEPENDS += " \
24 ${PYTHON_PN}-ply-native \
25 ${PYTHON_PN}-pyyaml-native \
26 ${PYTHON_PN}-six-native \
27 ${PYTHON_PN}-wheel-native \
28"
29
30RDEPENDS:${PN}:class-target += "\
31 ${PYTHON_PN}-datetime \
32 ${PYTHON_PN}-io \
33 ${PYTHON_PN}-netclient \
34 ${PYTHON_PN}-ply \
35 ${PYTHON_PN}-pyyaml \
36 ${PYTHON_PN}-six \
37 ${PYTHON_PN}-stringold \
38 ${PYTHON_PN}-threading \
39 ${PYTHON_PN}-unixadmin \
40 ${PYTHON_PN}-xml \
41 ${PYTHON_PN}-nocasedict \
42 ${PYTHON_PN}-nocaselist \
43 ${PYTHON_PN}-yamlloader \
44"
45
46ALTERNATIVE:${PN} = "mof_compiler"
47ALTERNATIVE_TARGET[mof_compiler] = "${bindir}/mof_compiler"
48
49ALTERNATIVE_PRIORITY = "60"
50
51BBCLASSEXTEND = "native"