blob: 457b965481d086724fdadd5d0503ed4a145b5b72 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "Linux control group abstraction library"
2HOMEPAGE = "http://libcg.sourceforge.net/"
3DESCRIPTION = "libcgroup is a library that abstracts the control group file system \
4in Linux. Control groups allow you to limit, account and isolate resource usage \
5(CPU, memory, disk I/O, etc.) of groups of processes."
6SECTION = "libs"
7LICENSE = "LGPL-2.1-only"
8LIC_FILES_CHKSUM = "file://COPYING;md5=4d794c5d710e5b3547a6cc6a6609a641"
9
Andrew Geissler87f5cff2022-09-30 13:13:31 -050010inherit autotools pkgconfig github-releases
Patrick Williams92b42cb2022-09-03 06:53:57 -050011
12DEPENDS = "bison-native flex-native"
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060013DEPENDS:append:libc-musl = " fts"
Patrick Williams92b42cb2022-09-03 06:53:57 -050014
Andrew Geissler87f5cff2022-09-30 13:13:31 -050015SRC_URI = "${GITHUB_BASE_URI}/download/v3.0/${BP}.tar.gz \
Patrick Williams92b42cb2022-09-03 06:53:57 -050016 file://0001-api-Use-GNU-strerror_r-when-available.patch \
17"
Andrew Geissler87f5cff2022-09-30 13:13:31 -050018UPSTREAM_CHECK_URI = "https://github.com/libcgroup/libcgroup/tags"
Patrick Williams92b42cb2022-09-03 06:53:57 -050019
20SRC_URI[sha256sum] = "8d284d896fca1c981b55850e92acd3ad9648a69227c028dda7ae3402af878edd"
Patrick Williams92b42cb2022-09-03 06:53:57 -050021
Patrick Williams92b42cb2022-09-03 06:53:57 -050022PACKAGECONFIG = "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)}"
23PACKAGECONFIG[pam] = "--enable-pam-module-dir=${base_libdir}/security --enable-pam=yes,--enable-pam=no,libpam"
24
25PACKAGES =+ "cgroups-pam-plugin"
26FILES:cgroups-pam-plugin = "${base_libdir}/security/pam_cgroup.so*"
27FILES:${PN}-dev += "${base_libdir}/security/*.la"
28FILES:${PN}-staticdev += "${base_libdir}/security/pam_cgroup.a"
29
30do_install:append() {
31 # Until we ship the test suite, this library isn't useful
32 rm -f ${D}${libdir}/libcgroupfortesting.*
33}