blob: 9f58a4bf1ff04572a016b2a619ed45bd6ddc33ef [file] [log] [blame]
Andrew Geissler6ce62a22020-11-30 19:58:47 -06001DESCRIPTION = "Powerful Python library for atomic file writes"
2HOMEPAGE = "https://github.com/untitaker/python-atomicwrites"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=91cc36cfafeefb7863673bcfcb1d4da4"
5
Andrew Geissler615f2f12022-07-15 14:00:58 -05006SRC_URI[sha256sum] = "81b2c9071a49367a7f770170e5eec8cb66567cfbbc8c73d20ce5ca4a8d71cf11"
Andrew Geissler6ce62a22020-11-30 19:58:47 -06007
8inherit pypi setuptools3 ptest
9
10SRC_URI += " \
11 file://run-ptest \
12"
13
Patrick Williams213cb262021-08-07 19:21:33 -050014RDEPENDS:${PN}-ptest += " \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060015 ${PYTHON_PN}-pytest \
16 ${PYTHON_PN}-unixadmin \
17"
18
19do_install_ptest() {
20 install -d ${D}${PTEST_PATH}/tests
21 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
22}
23
Patrick Williams213cb262021-08-07 19:21:33 -050024RDEPENDS:${PN} = "${PYTHON_PN}-misc"
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060025
26BBCLASSEXTEND = "native nativesdk"