blob: e1f2a49d31bb3f28f2911c7f221e2341a8253ab1 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "unittest subTest() support and subtests fixture."
2DESCRIPTION = "Adds support for TestCase.subTest.\
3New subtests fixture, providing similar functionality for pure pytest tests."
4HOMEPAGE = "https://github.com/pytest-dev/pytest-subtests"
5BUGTRACKER = "https://github.com/pytest-dev/pytest-subtests/issues"
6
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=242b4e17fa287dcf7aef372f6bc3dcb1"
9
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060010SRC_URI[sha256sum] = "d9961a67c1791e8c1e32dce7a70ed1e54f3b1e641087f2094f2d37087ab7fb17"
Andrew Geissler9aee5002022-03-30 16:27:02 +000011
12inherit pypi setuptools3
13
14DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
15
16RDEPENDS:${PN} += " \
17 ${PYTHON_PN}-pytest \
18"
19
20BBCLASSEXTEND = "native nativesdk"