blob: cd7f41a0165a5de0ff612ff53898f4bfcd6c77f2 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "System load testing utility"
2DESCRIPTION = "Deliberately simple workload generator for POSIX systems. It \
3imposes a configurable amount of CPU, memory, I/O, and disk stress on the system."
4HOMEPAGE = "https://github.com/ColinIanKing/stress-ng#readme"
5LICENSE = "GPL-2.0-only"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
8SRC_URI = "git://github.com/ColinIanKing/stress-ng.git;protocol=https;branch=master \
Andrew Geisslerc5535c92023-01-27 16:10:19 -06009 file://0001-test-float-Make-variables-global.patch \
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060010 file://0001-Include-sys-futex.h-for-clock_adjtime.patch \
Andrew Geissler517393d2023-01-13 08:55:19 -060011 file://0001-Pass-LD_GOLD-1-via-makefile-to-enable-gold-linker.patch"
Patrick Williams864cc432023-02-09 14:54:44 -060012SRCREV = "f3be0447c10fd5652b4c3753d56bcaac13fd8917"
Andrew Geissler517393d2023-01-13 08:55:19 -060013S = "${WORKDIR}/git"
14
15DEPENDS = "coreutils-native libbsd"
16
17PROVIDES = "stress"
18RPROVIDES:${PN} = "stress"
19RREPLACES:${PN} = "stress"
20RCONFLICTS:${PN} = "stress"
21
22inherit bash-completion
23
24EXTRA_OEMAKE = "VERBOSE=1"
25
26do_configure() {
27 mkdir -p configs
28 touch configs/HAVE_APPARMOR
29 oe_runmake makeconfig
30}
31
32do_install() {
33 oe_runmake DESTDIR=${D} BINDIR=${bindir} install
34 ln -s stress-ng ${D}${bindir}/stress
35}