blob: 2131f46213cc6a46ccac2b9c517401eb2698aa15 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Xlib: Compose data files for libx11"
2DESCRIPTION = "This package provides the compose data files for libx11."
3
4python () {
5 if bb.utils.contains('DISTRO_FEATURES', 'x11', True, False, d):
6 raise bb.parse.SkipRecipe("libx11-compose-data is incompatible with x11 distro feature, use libx11 instead.")
7}
8
9require xorg-lib-common.inc
10
11LICENSE = "MIT & BSD-1-Clause & HPND & HPND-sell-variant & ISC"
12LIC_FILES_CHKSUM = "file://COPYING;md5=1d49cdd2b386c5db11ec636d680b7116"
13
14XORG_PN = "libX11"
15
16SRC_URI += "file://0001-Drop-x11-dependencies.patch \
17 "
18
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060019SRC_URI[sha256sum] = "c9a287a5aefa9804ce3cfafcf516fe96ed3f7e8e45c0e2ee59e84c86757df518"
Andrew Geissler517393d2023-01-13 08:55:19 -060020
21REQUIRED_DISTRO_FEATURES = ""
22
23EXTRA_OECONF += "--disable-xkb"
24
25do_compile() {
26 oe_runmake -C nls
27}
28
29do_install() {
30 oe_runmake DESTDIR=${D} -C nls install
31}
32
33PACKAGES = "${PN}"
34
35FILES:${PN} = "${datadir}/X11/locale ${libdir}/X11/locale"