blob: 8a703f533e0b3decc9b39bc79cf5a2a468dca106 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "VA-API support to GStreamer"
2HOMEPAGE = "https://gstreamer.freedesktop.org/"
3DESCRIPTION = "gstreamer-vaapi consists of a collection of VA-API \
4based plugins for GStreamer and helper libraries: `vaapidecode', \
5`vaapiconvert', and `vaapisink'."
6
7REALPN = "gstreamer-vaapi"
8
9LICENSE = "LGPL-2.1-or-later"
10LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
11
12SRC_URI = "https://gstreamer.freedesktop.org/src/${REALPN}/${REALPN}-${PV}.tar.xz"
13
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060014SRC_URI[sha256sum] = "593ccad19f88e5fa29f40f98356c007806bd535828707b1406944d16a90bdff5"
Andrew Geissler517393d2023-01-13 08:55:19 -060015
16S = "${WORKDIR}/${REALPN}-${PV}"
17DEPENDS = "libva gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad"
18
19inherit meson pkgconfig features_check upstream-version-is-even
20
21REQUIRED_DISTRO_FEATURES ?= "opengl"
22
23EXTRA_OEMESON += " \
24 -Ddoc=disabled \
25 -Dexamples=disabled \
26 -Dtests=enabled \
27"
28
29PACKAGES =+ "${PN}-tests"
30
31# OpenGL packageconfig factored out to make it easy for distros
32# and BSP layers to pick either glx, egl, or no GL. By default,
33# try detecting X11 first, and if found (with OpenGL), use GLX,
34# otherwise try to check if EGL can be used.
35PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'glx', \
36 bb.utils.contains('DISTRO_FEATURES', 'opengl', 'egl', \
37 '', d), d)}"
38
39PACKAGECONFIG ??= "drm encoders \
40 ${PACKAGECONFIG_GL} \
41 ${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}"
42
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060043PACKAGECONFIG[drm] = "-Ddrm=enabled,-Ddrm=disabled,udev libdrm"
44PACKAGECONFIG[egl] = "-Degl=enabled,-Degl=disabled,virtual/egl"
45PACKAGECONFIG[encoders] = "-Dencoders=enabled,-Dencoders=disabled"
46PACKAGECONFIG[glx] = "-Dglx=enabled,-Dglx=disabled,virtual/libgl"
47PACKAGECONFIG[wayland] = "-Dwayland=enabled,-Dwayland=disabled,wayland-native wayland wayland-protocols"
48PACKAGECONFIG[x11] = "-Dx11=enabled,-Dx11=disabled,virtual/libx11 libxrandr libxrender"
Andrew Geissler517393d2023-01-13 08:55:19 -060049
50FILES:${PN} += "${libdir}/gstreamer-*/*.so"
51FILES:${PN}-dbg += "${libdir}/gstreamer-*/.debug"
52FILES:${PN}-dev += "${libdir}/gstreamer-*/*.a"
53FILES:${PN}-tests = "${bindir}/*"
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060054
55# correct .pc install location - fixed in upstream trunk
56do_install:append() {
57 mkdir -p ${D}/${libdir}/pkgconfig
58 mv ${D}/${libdir}/gstreamer-1.0/pkgconfig/*.pc ${D}/${libdir}/pkgconfig
59 rmdir ${D}/${libdir}/gstreamer-1.0/pkgconfig/
60}