blob: a7b0de44a5a50ae53bf767a8a54c5bbc27a23460 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "High-level GnuPG encryption/signing API"
2DESCRIPTION = "GnuPG Made Easy (GPGME) is a library designed to make access to GnuPG easier for applications. It provides a High-Level Crypto API for encryption, decryption, signing, signature verification and key management"
3HOMEPAGE = "http://www.gnupg.org/gpgme.html"
4BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
5
6LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later"
7LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
8 file://COPYING.LESSER;md5=bbb461211a33b134d42ed5ee802b37ff \
9 file://src/gpgme.h.in;endline=23;md5=2f0bf06d1c7dcb28532a9d0f94a7ca1d \
10 file://src/engine.h;endline=22;md5=4b6d8ba313d9b564cc4d4cfb1640af9d"
11
12UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
13SRC_URI = "${GNUPG_MIRROR}/gpgme/${BP}.tar.bz2 \
14 file://0001-Revert-build-Make-gpgme.m4-use-gpgrt-config-with-.pc.patch \
15 file://0001-pkgconfig.patch \
16 file://0002-gpgme-lang-python-gpg-error-config-should-not-be-use.patch \
17 file://0003-Correctly-install-python-modules.patch \
18 file://0004-python-import.patch \
19 file://0005-gpgme-config-skip-all-lib-or-usr-lib-directories-in-.patch \
20 file://0006-fix-build-path-issue.patch \
21 file://0007-python-Add-variables-to-tests.patch \
22 file://0008-do-not-auto-check-var-PYTHON.patch \
23 file://0001-use-closefrom-on-linux-and-glibc-2.34.patch \
Andrew Geissler517393d2023-01-13 08:55:19 -060024 file://0001-posix-io.c-Use-off_t-instead-of-off64_t.patch \
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060025 file://0001-autogen.sh-remove-unknown-in-version.patch \
Patrick Williams92b42cb2022-09-03 06:53:57 -050026 "
27
28SRC_URI[sha256sum] = "361d4eae47ce925dba0ea569af40e7b52c645c4ae2e65e5621bf1b6cdd8b0e9e"
29
Patrick Williams7784c422022-11-17 07:29:11 -060030PYTHON_DEPS = "${@bb.utils.contains('LANGUAGES', 'python', 'swig-native', '', d)}"
31
32DEPENDS = "libgpg-error libassuan ${PYTHON_DEPS}"
Patrick Williams92b42cb2022-09-03 06:53:57 -050033RDEPENDS:${PN}-cpp += "libstdc++"
34
Patrick Williams92b42cb2022-09-03 06:53:57 -050035RDEPENDS:python3-gpg += "python3-unixadmin"
36
37BINCONFIG = "${bindir}/gpgme-config"
38
Patrick Williams92b42cb2022-09-03 06:53:57 -050039# Default in configure.ac: "cl cpp python qt"
40# Supported: "cl cpp python python2 python3 qt"
41# python says 'search and find python2 or python3'
42
43# Building the C++ bindings for native requires a C++ compiler with C++11
44# support. Since these bindings are currently not needed, we can disable them.
45DEFAULT_LANGUAGES = ""
46DEFAULT_LANGUAGES:class-target = "cpp"
47LANGUAGES ?= "${DEFAULT_LANGUAGES} python"
48
Patrick Williams7784c422022-11-17 07:29:11 -060049PYTHON_INHERIT = "${@bb.utils.contains('LANGUAGES', 'python', 'setuptools3-base', '', d)}"
Patrick Williams92b42cb2022-09-03 06:53:57 -050050
51EXTRA_OECONF += '--enable-languages="${LANGUAGES}" \
52 --disable-gpgconf-test \
53 --disable-gpg-test \
54 --disable-gpgsm-test \
55 --disable-g13-test \
56 --disable-lang-python-test \
57'
58
Patrick Williams7784c422022-11-17 07:29:11 -060059inherit autotools texinfo binconfig-disabled pkgconfig ${PYTHON_INHERIT} python3native multilib_header
Patrick Williams92b42cb2022-09-03 06:53:57 -050060
61export PKG_CONFIG='pkg-config'
62
63BBCLASSEXTEND = "native nativesdk"
64
Patrick Williams7784c422022-11-17 07:29:11 -060065PACKAGES =+ "${PN}-cpp python3-gpg"
Patrick Williams92b42cb2022-09-03 06:53:57 -050066
67FILES:${PN}-cpp = "${libdir}/libgpgmepp.so.*"
Patrick Williams92b42cb2022-09-03 06:53:57 -050068FILES:python3-gpg = "${PYTHON_SITEPACKAGES_DIR}/*"
69FILES:${PN}-dev += "${datadir}/common-lisp/source/gpgme/*"
70
71CFLAGS:append:libc-musl = " -D__error_t_defined "
72do_configure:prepend () {
73 # Else these could be used in preference to those in aclocal-copy
74 rm -f ${S}/m4/gpg-error.m4
75 rm -f ${S}/m4/libassuan.m4
76 rm -f ${S}/m4/python.m4
77}
78
79do_install:append() {
80 oe_multilib_header gpgme.h
81}