blob: f57a15954d83b36a08e926e847d2a61e8c4630ba [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "HTTP/2 C Library and tools"
2HOMEPAGE = "https://nghttp2.org/"
3SECTION = "libs"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=764abdf30b2eadd37ce47dcbce0ea1ec"
6
7SRC_URI = "\
8 ${GITHUB_BASE_URI}/download/v${PV}/nghttp2-${PV}.tar.xz \
9 file://0001-fetch-ocsp-response-use-python3.patch \
10"
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060011SRC_URI[sha256sum] = "3ea9f0439e60469ad4d39cb349938684ffb929dd7e8e06a7bffe9f9d21f8ba7d"
Andrew Geissler517393d2023-01-13 08:55:19 -060012
13inherit cmake manpages python3native github-releases
14PACKAGECONFIG[manpages] = ""
15
16# examples are never installed, and don't need to be built in the
17# first place
Patrick Williams864cc432023-02-09 14:54:44 -060018EXTRA_OECMAKE = "-DENABLE_EXAMPLES=OFF -DENABLE_APP=OFF -DENABLE_HPACK_TOOLS=OFF -DENABLE_PYTHON_BINDINGS=OFF"
Andrew Geissler517393d2023-01-13 08:55:19 -060019
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060020PACKAGES =+ "lib${BPN} ${PN}-proxy "
Andrew Geissler517393d2023-01-13 08:55:19 -060021
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060022RDEPENDS:${PN} = "${PN}-proxy (>= ${PV})"
Andrew Geissler517393d2023-01-13 08:55:19 -060023RDEPENDS:${PN}:class-native = ""
24RDEPENDS:${PN}-proxy = "openssl python3-core python3-io python3-shell"
25
26ALLOW_EMPTY:${PN} = "1"
27FILES:${PN} = ""
28FILES:lib${BPN} = "${libdir}/*${SOLIBS}"
Andrew Geissler517393d2023-01-13 08:55:19 -060029FILES:${PN}-proxy = "${bindir}/nghttpx ${datadir}/${BPN}/fetch-ocsp-response"
Andrew Geissler517393d2023-01-13 08:55:19 -060030
31BBCLASSEXTEND = "native nativesdk"