Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 1 | SUMMARY = "Invoke py.test as distutils command with dependency resolution" |
| 2 | HOMEPAGE = "https://pypi.org/project/pytest-runner/" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=7a7126e068206290f3fe9f8d6c713ea6" |
| 5 | |
| 6 | SRC_URI[sha256sum] = "b4d85362ed29b4c348678de797df438f0f0509497ddb8c647096c02a6d87b685" |
| 7 | |
| 8 | inherit pypi python_setuptools_build_meta |
| 9 | |
| 10 | DEPENDS += " \ |
| 11 | ${PYTHON_PN}-setuptools-scm-native" |
| 12 | |
| 13 | RDEPENDS:${PN} = "${PYTHON_PN}-py ${PYTHON_PN}-setuptools ${PYTHON_PN}-debugger ${PYTHON_PN}-json \ |
| 14 | ${PYTHON_PN}-io ${PYTHON_PN}-distutils" |
| 15 | |
| 16 | BBCLASSEXTEND = "native nativesdk" |