Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 1 | SUMMARY = "Flex (The Fast Lexical Analyzer)" |
| 2 | DESCRIPTION = "Flex is a fast lexical analyser generator. Flex is a tool for generating programs that recognize \ |
| 3 | lexical patterns in text." |
| 4 | HOMEPAGE = "http://sourceforge.net/projects/flex/" |
| 5 | SECTION = "devel" |
| 6 | LICENSE = "BSD" |
| 7 | |
| 8 | DEPENDS = "${@bb.utils.contains('PTEST_ENABLED', '1', 'bison-native flex-native', '', d)}" |
| 9 | BBCLASSEXTEND = "native nativesdk" |
| 10 | |
| 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=e4742cf92e89040b39486a6219b68067" |
| 12 | |
| 13 | SRC_URI = "${SOURCEFORGE_MIRROR}/flex/flex-${PV}.tar.bz2 \ |
| 14 | file://run-ptest \ |
| 15 | file://do_not_create_pdf_doc.patch \ |
| 16 | file://0001-tests-add-a-target-for-building-tests-without-runnin.patch \ |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 17 | file://0002-avoid-c-comments-in-c-code-fails-with-gcc-6.patch \ |
| 18 | file://CVE-2016-6354.patch \ |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 19 | ${@bb.utils.contains('PTEST_ENABLED', '1', '', 'file://disable-tests.patch', d)} \ |
| 20 | " |
| 21 | |
| 22 | SRC_URI[md5sum] = "266270f13c48ed043d95648075084d59" |
| 23 | SRC_URI[sha256sum] = "24e611ef5a4703a191012f80c1027dc9d12555183ce0ecd46f3636e587e9b8e9" |
| 24 | |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 25 | # Flex has moved to github from 2.6.1 onwards |
| 26 | UPSTREAM_CHECK_URI = "https://github.com/westes/flex/releases" |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 27 | UPSTREAM_CHECK_REGEX = "flex-(?P<pver>\d+(\.\d+)+)\.tar" |
| 28 | |
| 29 | inherit autotools gettext texinfo ptest |
| 30 | |
| 31 | M4 = "${bindir}/m4" |
| 32 | M4_class-native = "${STAGING_BINDIR_NATIVE}/m4" |
| 33 | EXTRA_OECONF += "ac_cv_path_M4=${M4}" |
| 34 | EXTRA_OEMAKE += "m4=${STAGING_BINDIR_NATIVE}/m4" |
| 35 | |
| 36 | EXTRA_OEMAKE += "${@bb.utils.contains('PTEST_ENABLED', '1', 'FLEX=${STAGING_BINDIR_NATIVE}/flex', '', d)}" |
| 37 | |
| 38 | do_install_append_class-native() { |
| 39 | create_wrapper ${D}/${bindir}/flex M4=${M4} |
| 40 | } |
| 41 | |
| 42 | do_install_append_class-nativesdk() { |
| 43 | create_wrapper ${D}/${bindir}/flex M4=${M4} |
| 44 | } |
| 45 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 46 | PACKAGES =+ "${PN}-libfl" |
| 47 | |
| 48 | FILES_${PN}-libfl = "${libdir}/libfl.so.* ${libdir}/libfl_pic.so.*" |
| 49 | |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 50 | RDEPENDS_${PN} += "m4" |
| 51 | RDEPENDS_${PN}-ptest += "bash gawk" |
| 52 | |
| 53 | do_compile_ptest() { |
| 54 | oe_runmake -C ${B}/tests -f ${B}/tests/Makefile top_builddir=${B} INCLUDES=-I${S}/src buildtests |
| 55 | } |
| 56 | |
| 57 | do_install_ptest() { |
| 58 | mkdir -p ${D}${PTEST_PATH}/build-aux/ |
| 59 | cp ${S}/build-aux/test-driver ${D}${PTEST_PATH}/build-aux/ |
| 60 | cp -r ${S}/tests/* ${D}${PTEST_PATH} |
| 61 | cp -r ${B}/tests/* ${D}${PTEST_PATH} |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 62 | sed -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \ |
| 63 | -e 's|${DEBUG_PREFIX_MAP}||g' \ |
| 64 | -e 's:${HOSTTOOLS_DIR}/::g' \ |
| 65 | -e 's:${RECIPE_SYSROOT_NATIVE}::g' \ |
| 66 | -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \-e 's/^Makefile:/_Makefile:/' \ |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 67 | -e 's/^srcdir = \(.*\)/srcdir = ./' -e 's/^top_srcdir = \(.*\)/top_srcdir = ./' \ |
| 68 | -e 's/^builddir = \(.*\)/builddir = ./' -e 's/^top_builddir = \(.*\)/top_builddir = ./' \ |
| 69 | -i ${D}${PTEST_PATH}/Makefile |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 70 | } |