blob: d4812c0f0a0fdfe73b3b3cda4f3b3f5d7dbc593f [file] [log] [blame]
Andrew Geisslerc9f78652020-09-18 14:11:35 -05001require go-${PV}.inc
2require go-target.inc
3
4inherit linuxloader
5
6export GOBUILDMODE=""
7export CGO_ENABLED_riscv64 = ""
8export GO_LDSO = "${@get_linuxloader(d)}"
Andrew Geissler6ce62a22020-11-30 19:58:47 -06009export CC_FOR_TARGET = "gcc"
10export CXX_FOR_TARGET = "g++"
Andrew Geisslerc9f78652020-09-18 14:11:35 -050011
12# mips/rv64 doesn't support -buildmode=pie, so skip the QA checking for mips/riscv and its
13# variants.
14python() {
15 if 'mips' in d.getVar('TARGET_ARCH',True) or 'riscv' in d.getVar('TARGET_ARCH',True):
16 d.appendVar('INSANE_SKIP_%s' % d.getVar('PN',True), " textrel")
17}
Andrew Geissler6ce62a22020-11-30 19:58:47 -060018