blob: b916a7fe600fc8e6179d32853b2972656a73463f [file] [log] [blame]
Patrick Williamsc0f7c042017-02-23 20:41:17 -06001SUMMARY = "Real-Time preemption testcases"
2HOMEPAGE = "https://rt.wiki.kernel.org/index.php/Cyclictest"
3SECTION = "tests"
Andrew Geissler6ce62a22020-11-30 19:58:47 -06004DEPENDS = "linux-libc-headers virtual/libc numactl"
Patrick Williamsc0f7c042017-02-23 20:41:17 -06005LICENSE = "GPLv2 & GPLv2+"
Andrew Geissler6ce62a22020-11-30 19:58:47 -06006LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
Patrick Williamsc0f7c042017-02-23 20:41:17 -06007
8require rt-tests.inc
9inherit ptest
10
11SRC_URI += " \
12 file://run-ptest \
13 file://rt_bmark.py \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060014 file://0001-Makefile-Allow-for-CC-and-AR-to-be-overridden.patch \
15 file://0001-rt-tests-oslat-Allow-build-for-not-supported-archs.patch \
Patrick Williamsc0f7c042017-02-23 20:41:17 -060016 "
Brad Bishop79641f22019-09-10 07:20:22 -040017
18# rt-tests needs PI mutex support in libc
19COMPATIBLE_HOST_libc-musl = 'null'
20
Patrick Williamsc0f7c042017-02-23 20:41:17 -060021# Do not install hwlatdetect
22EXTRA_OEMAKE += "PYLIB=''"
23
24do_install() {
25 oe_runmake install DESTDIR=${D} SBINDIR=${sbindir} MANDIR=${mandir} \
26 INCLUDEDIR=${includedir}
27}
28
29do_install_ptest() {
30 cp ${WORKDIR}/rt_bmark.py ${D}${PTEST_PATH}
31}
32
Brad Bishop08902b02019-08-20 09:16:51 -040033RDEPENDS_${PN}-ptest += " stress-ng python3 python3-multiprocessing python3-datetime python3-misc"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060034
35FILES_${PN} += "${prefix}/src/backfire"
Andrew Geissler6ce62a22020-11-30 19:58:47 -060036RDEPENDS_${PN} += "bash"