blob: ff4f4853367f11f414765840516927659fefc89e [file] [log] [blame]
Brad Bishopb1e88402017-01-11 11:12:32 -05001SUMMARY = "OpenBMC hwmon poller"
2DESCRIPTION = "OpenBMC hwmon poller."
3PR = "r1"
4
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
7
Brad Bishop4186efb2017-01-11 15:30:07 -05008inherit autotools pkgconfig obmc-phosphor-systemd
9
10SYSTEMD_SERVICE_${PN} = "xyz.openbmc_project.Hwmon@.service"
Brad Bishopb1e88402017-01-11 11:12:32 -050011
12DEPENDS += "autoconf-archive-native"
Brad Bishop6d105112017-02-20 14:36:31 -050013DEPENDS += " \
14 sdbusplus \
15 phosphor-dbus-interfaces \
16 phosphor-logging \
17 "
18
Brad Bishopb1e88402017-01-11 11:12:32 -050019
20RDEPENDS_${PN} += "\
Brad Bishop6d105112017-02-20 14:36:31 -050021 sdbusplus \
22 phosphor-dbus-interfaces \
23 phosphor-logging \
Brad Bishopb1e88402017-01-11 11:12:32 -050024 "
25
26SRC_URI += "git://github.com/openbmc/phosphor-hwmon"
Brad Bishop4186efb2017-01-11 15:30:07 -050027SRC_URI += "file://70-hwmon.rules"
Brad Bishopb1e88402017-01-11 11:12:32 -050028
Patrick Williams60dc86d2017-02-20 08:00:07 -060029SRCREV = "bf86e72ebc4b33264ac0d8d6c8f0383f76b44e0f"
Brad Bishopb1e88402017-01-11 11:12:32 -050030
31S = "${WORKDIR}/git"
Brad Bishop4186efb2017-01-11 15:30:07 -050032
33do_install_append() {
34
Brad Bishop2b9921e2017-01-26 09:12:57 -050035 install -d ${D}/${base_libdir}/udev/rules.d/
36 install ${WORKDIR}/70-hwmon.rules ${D}/${base_libdir}/udev/rules.d/
Brad Bishop4186efb2017-01-11 15:30:07 -050037}