blob: fd78306cf5611493abec40930bdc5677a184a8ef [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001DESCRIPTION = "Python API for MISP"
2HOMEPAGE = "https://github.com/MISP/PyMISP"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=a3639cf5780f71b125d3e9d1dc127c20"
5
6SRC_URI = "git://github.com/MISP/PyMISP.git;protocol=https;branch=main"
Andrew Geisslerfc113ea2023-03-31 09:59:46 -05007SRCREV = "9e2712bb1da00c7bd3559f978c6316ca0287d453"
Andrew Geissler517393d2023-01-13 08:55:19 -06008S = "${WORKDIR}/git"
9
10inherit python_poetry_core
11
12PIP_INSTALL_PACKAGE = "pymisp"
13
14RDEPENDS:${PN} += " \
15 ${PYTHON_PN}-dateutil \
16 ${PYTHON_PN}-json \
17 ${PYTHON_PN}-jsonschema \
18 ${PYTHON_PN}-requests \
19 ${PYTHON_PN}-six \
20 ${PYTHON_PN}-deprecated \
21 ${PYTHON_PN}-wrapt \
22"
23
24# Fixes: python3-pymisp requires /bin/bash, but no
25# providers found in RDEPENDS:python3-pymisp? [file-rdep]
26RDEPENDS:${PN} += "bash"